Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmento - TOTVS Backoffice (Linha RM) - Documentos Eletrônicos - Erro no envio da NFS-e Layout Nacional - Element '{http://www.sped.fazenda.gov.br/nfse}cNaoNIF': This element is not expected. Expected is one of ({http://www.sped.fazenda.gov.br/nfse

time.pngTempo aproximado para leitura: 00:01:30 min

Ocorrência

No módulo TOTVS Gestão de Estoque, Compras e Faturamento, ao realizar o envio de uma Nota Fiscal de Serviço Eletrônica (NFS-e) utilizando o Layout Nacional, é retornada a seguinte inconsistência:
"Element '{http://www.sped.fazenda.gov.br/nfse}cNaoNIF': This element is not expected. Expected is one of ({http://www.sped.fazenda.gov.br/nfse}CAEPF, {http://www.sped.fazenda.gov.br/nfse}IM, {http://www.sped.fazenda.gov.br/nfse}xNome)."

Ambiente
Cross Segmento - TOTVS Backoffice (Linha RM) - Documentos Eletrônicos - Todas as versões.

Causa 
A inconsistência ocorre devido à validação referente à tag CAEPF
Embora esta tag não seja de preenchimento obrigatório no RM, o uso do TSS (TOTVS Sped Service) desatualizado faz com que a mensagem de inconsistência seja retornada pelo aplicativo.

Solução
A atualização dos componentes do TSS corrige o comportamento, permitindo que a nota seja validada corretamente sem a exigência indevida desta tag.

Caso seu TSS esteja numa versão anterior a 12.1.2410, será necessário efetuar a migração para tal versão.

Caso seu TSS já esteja na versão 12.1.2410, é necessário apenas efetuar a atualização dos pacotes.

A documentação abaixo contém os passos tanto de instalação quanto da atualização do TSS.

Cross Segmentos - TOTVS Backoffice (Linha RM) - Doc. Eletrônicos - Instalação e atualização do TSS 12.1.2410


Conheça nossas documentações referente a NFSE Nacional clicando no link abaixo:
Nota Fiscal de Serviço Eletrônica - Layout Nacional (NAC)

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _