Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

RH - RM - FOP - Integração RM Labore x BackOffice Protheus - Erro ao gerar WSDL do endereço http://localhost:8050/EAISERVICE.apw?WSDL


time.png Tempo aproximado para leitura: 00:03:25 min

Ocorrência
Ao tentar realizar integrações entre RM e Protheus, ocorre o erro: "Erro ao gerar WSDL do endereço http://localhost:8051/EAISERVICE.apw?WSDL

Ambiente
TOTVS RH - TOTVS RH (Linha RM) - TOTVS Folha de Pagamento - Todas as versões

Causa 
O erro indica que o a URL do Webservice do RM está informado errado no Protheus, especificamente no parâmetro MV_EAIURL2 do Protheus.

Solução
Para solucionar essa ocorrência, você deve acessar o endereço do Webservice do RM, geralmente com o final wspageindex (exemplo: http://localhost:8051/wsPageIndex/) e acessar o menu EAIService.

 

Muitos usuários se confundem copiando a URL desta página para informar no parâmetro MV_EAIURL2 ou no Configurador do EAI 2.0, mas o endereço correto está no fim dessa página com o final IConWSEAIService (exemplo de URL: http://localhost:8051/EAIService/IConWSEAIService)
 

 

Observação

Esse endereço exemplo de URL: http://localhost:8051/EAIService/IConWSEAIService não irá abrir no navegador que muitos utilizam como teste pois o é um endpoint.

 

Outro possível motivo para a ocorrência do erro, mesmo com a URL correta, é a falha de comunicação entre o servidor do RM e o servidor do Protheus.

Nesses casos, é importante validar a conectividade entre os ambientes, acessando via navegador, a partir do servidor do RM, os serviços (Webservice e REST) do Protheus, e, da mesma forma, acessar o Webservice do RM a partir do servidor do Protheus.

Essa validação ajuda a identificar possíveis bloqueios de rede. Caso sejam encontrados impedimentos, será necessário acionar a equipe de infraestrutura para liberação da comunicação entre os servidores

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _