Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

RH - RM - Meu RH - Erro "AADSTS50011: The redirect URI does not match" no login via Azure

time.png Tempo aproximado para leitura: 00:03:00 min

Ocorrência
Ao realizar o login no Meu RH utilizando a integração com Azure, o código de erro apresentado é o AADSTS50011 (que indica uma divergência na URI de redirecionamento configurada).

Ambiente
TOTVS RH - TOTVS RH (Linha RM) - Meu RH - A partir do release 12.1.33.158

Causa 
O erro é referente à URL incorreta como descrito na própria mensagem, provavelmente está faltando ou passando uma / no fim do endereço ou alguma letra maiúscula/minúscula está diferente da URL informada no Azure pois o campo é case sensitive.

Solução
Na mensagem de erro, é apresentada exatamente a URL que deve ser informada no campo de Autenticação | Adicionar URL de Redirecionamento | Aplicativo de Página Única pois o campo é case sensitive, ou seja, sistema faz a diferenciação rigorosa entre letras maiúsculas e minúsculas.

Isso significa que o sistema entende a letra "A" como um caractere completamente diferente da letra "a".

No exemplo abaixo, a URL foi informada como http://localhost/FrameHTML/web/App/RH/PortalMeuRH e no erro foi informado que a URL esperada era http://localhost/FrameHTML/Web/App/RH/PortalMeuRH em que estava diferente apenas o W maiúsculo entre uma URL e  outra.
 


 

Basta copiar exatamente a URL do erro "AADSTS50011: The redirect URI 'http://localhost/FrameHTML/web/app/RH/PortalMeuRH' specified in the request does not match the redirect URIs" e informar no campo da plataforma do Azure em Autenticação | Adicionar URL de Redirecionamento | Aplicativo de Página Única e tentar novamente conforme o exemplo a seguir:

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _