Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - Backoffice RM - Integração - SmartLink - Erro na Ativação SmartLink


time.png Tempo aproximado para leitura: 00:01:00 min

Ocorrência
Ocorreu um erro ao buscar as credenciais de ativação do TotvsApps no Credential Helper!



Ambiente
Cross Segmentos - Backoffice RM - Integração - A partir da 12.1.2506.
 

Causa 
O Smart Link utiliza um mecanismo de requisições HTTP para endpoints denominados generate_204 para validar a conectividade. Se o servidor de aplicação tiver bloqueios de firewall ou falta de acesso à internet para esses endereços específicos, o processo de ativação falhará. Além da conectividade, a ativação exige que requisitos de versão, patch e permissões de licença estejam devidamente configurados no ambiente.

Solução
Para solucionar essa ocorrência, realize os seguintes passos:

1- Verifique se o produto RM está na versão 12.1.2506 ou superior, com os patches atualizados.
2- Valide se o tipo de ambiente no RM está configurado como Produção 
3- Solicite à equipe de TI a liberação (whitelist) no Firewall para os seguintes endpoints de conectividade:

   http://google.com/generate_204 
   http://gstatic.com/generate_204 
   http://clients3.google.com/generate_204 
   http://cp.cloudflare.com/generate_204 
   http://edge-http.microsoft.com/captiveportal/generate_204 

4- Adicionalmente, garanta a liberação dos domínios e APIs de serviço:
   https://admin.rac.totvs.app 
   https://provisioning.totvs.app 
   https://app.carol.ai 
   https://api-smartlink.dev.totvs.app 
   https://api-credentialhelper.totvs.app 


5- Recomenda-se a liberação geral para o domínio *.totvs.app.

Após as liberações, tente realizar a ativação novamente através do console do RM

Saiba Mais
Smart Link - Requisitos de Ativação 
Credential Helper e Smart Link

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _