Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

RH - RM - FOP - Erro "Você não está autorizado" ou "Usuário logado não tem privilégios" ao conectar em DataServers ou API do RM RH

time.png Tempo aproximado para leitura: 00:03:00 min

Ocorrência
Ao tentar consumir DataServers ou APIs do RM, é apresentada uma das seguintes mensagens de erro:

"Você não está autorizado a utilizar esta funcionalidade do sistema" ou "O usuário logado não tem privilégios suficientes para efetuar essa operação".

Ambiente
TOTVS RH - TOTVS RH (Linha RM) - TOTVS Folha de Pagamento - Todas as versões

Causa 
Este erro ocorre, quando o usuário utilizado na autenticação não possui permissões suficientes para acessar o produto (DataServer/API) que está sendo consumido.

Solução
Para realizar o consumo de DataServers ou APIs, é necessário que o usuário de autenticação esteja vinculado a um perfil de acesso que possua as permissões de acesso no produto que será consumido.

A permissão de acesso é feita através do módulo Serviços Globais > Segurança > Usuários. Em Sistema, selecione o produto desejado, exemplo, RH > Folha de pagamento. Em sequência, edite o usuário e através da aba Segurança, vincule o acesso nas coligadas que serão consultadas e associe em um Perfil que contenha a permissão liberada.

 

Exemplo 1: O DataServer "FopFuncData" pertence ao produto Folha de Pagamento.
Para consumi-lo, o usuário deve estar vinculado a um perfil da Folha que possua permissão de acesso ao cadastro de Funcionários.

 

Exemplo 2: O DataServer "RhuPessoaData" pertence ao produto Gestão de Pessoas.
Para consumi-lo, usuário deve estar vinculado a um perfil desse produto com permissão para o cadastro de Pessoas.

 

Importante: 

As permissões abaixo também devem estar obrigatoriamente habilitadas para o consumo via WebService/API devido as regras da LGPD:

  • No perfil Folha de Pagamento:  "Desconsiderar Filtro de Produto em WebService"

     

  • Nos perfis Gestão de Pessoas e Automação de Ponto: "Ignorar filtro de regra de produto"

 

 

O parâmetro "Valida regras via WebSevice" deve estar marcado deve estar habilitado em: Folha de Pagamento > Configurações > Parametrizador > Funcionário > Restrições Cadastrais


 

Uma forma prática de validar as permissões corretas, é acessando o RM com o mesmo usuário utilizado na integração e executar manualmente o mesmo processo (cadastro ou consulta) diretamente no sistema.

✔️ Se funcionar no RM, também funcionará via WebService/API.
❌ Se não funcionar, é necessário ajustar as permissões do Perfil em Acesso a Menus.

 

Saiba mais:

RH - RM - FOP - Como identificar e consumir DataServer e API disponíveis nos produtos de RH?

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _