Tempo aproximado para leitura: 00:02:00 min
Ocorrência
Após realizar o envio de um comunicado para o Meu RH, o status fica somente "Aguardando" e não atualiza para "Enviado".
Ambiente
TOTVS RH - TOTVS RH (Linha RM) - Meu RH - A partir da versão 12.1.2310.123
Causa
Este erro ocorre quando há alguma falha durante a execução do Job de envio do comunicado.
Solução
Para realizar o reenvio deste comunicado, siga os passos abaixo:
1. Acesse no RM a aba Ambiente > Gerenciamento de Jobs. Crie um filtro com a classe do processo = 'FopPushCommunicateRhProcess'
2. Localize na coluna 'Iniciado Em' a execução que ainda não foi finalizada e verifique qual é o nome do servidor que está responsável pela execução.
3. Acesse o Cockpit através do menu ambiente, localize o servidor que assumiu a execução do envio do comunicado e expanda a janela Informações de Processamento e memória. Na opção "Executar processos", clique na opção Stop, e depois clique na opção start para inicia-lo novamente:
4. Em Gerenciamento de Jobs, selecione o Job do comunicado que não foi enviado, e clique na opção Reiniciar Job:
Realizando este processo, será recriado uma nova execução do job deste comunicado com o mesmo ID Job. Aguarde o processo finalizar e assim que concluir, atualize a tela gestão de comunicados para validar a atualização do status para "Enviado".
Importante: Após a execução do job, caso o status apresente mensagem de erro, acesse o detalhamento da execução para verificar a descrição do erro retornado. Alguns exemplos de erros comuns:
- “Um ou mais erros”
- “O processo não pode acessar o arquivo”
- “Cadeia de caracteres não foi reconhecida como um booleano válido”
Para tratativa dessas ocorrências, consulte o TDN, onde estão disponíveis os principais erros mapeados e suas respectivas orientações de correção: TDN - Comunicados para o RH
Saiba mais
RH - RM - Meu RH - Como disponibilizar comunicados no Meu RH
0 Comentários