Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

RH - RM - Meu RH - Gestão de comunicados não envia, fica somente no status "Aguardando"

time.png Tempo aproximado para leitura: 00:02:00 min

Ocorrência
Após realizar o envio de um comunicado para o Meu RH, o status fica somente "Aguardando" e não atualiza para "Enviado".


Ambiente
TOTVS RH - TOTVS RH (Linha RM) - Meu RH - A partir da versão 12.1.2310.123

Causa 
Este erro ocorre quando há alguma falha durante a execução do Job de envio do comunicado.

Solução
Para realizar o reenvio deste comunicado, siga os passos abaixo:

1. Acesse no RM a aba Ambiente > Gerenciamento de Jobs. Crie um filtro com a classe do processo = 'FopPushCommunicateRhProcess'

 

2. Localize na coluna 'Iniciado Em' a execução que ainda não foi finalizada e verifique qual é o nome do servidor que está responsável pela execução.

 

3. Acesse o Cockpit através do menu ambiente, localize o servidor que assumiu a execução do envio do comunicado e expanda a janela Informações de Processamento e memória.  Na opção "Executar processos", clique na opção Stop, e depois clique na opção start para inicia-lo novamente:

 

4. Em Gerenciamento de Jobs, selecione o Job do comunicado que não foi enviado, e clique na opção Reiniciar Job:

 

Realizando este processo, será recriado uma nova execução do job deste comunicado com o mesmo ID Job. Aguarde o processo finalizar e assim que concluir, atualize a tela gestão de comunicados para validar a atualização do status para "Enviado".

 

Importante: Após a execução do job, caso o status apresente mensagem de erro, acesse o detalhamento da execução para verificar a descrição do erro retornado. Alguns exemplos de erros comuns:

  • “Um ou mais erros”
  • “O processo não pode acessar o arquivo”
  • “Cadeia de caracteres não foi reconhecida como um booleano válido”

Para tratativa dessas ocorrências, consulte o TDN, onde estão disponíveis os principais erros mapeados e suas respectivas orientações de correção: TDN - Comunicados para o RH

 

Saiba mais

RH - RM - Meu RH - Como disponibilizar comunicados no Meu RH
 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _