Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

RH - Linha Protheus - GPE - Compartilhamento SRY, SRM e RGA

time.png Tempo aproximado para leitura: 00:01:00 min

Ocorrência
Ao acessar a rotina de Cadastro de Roteiros o sistema gera a mensagem:
Help: O compartilhamento das tabelas SRY, SRM e RGA deve ser idêntico. Verifique a Configuração 

Ambiente
TOTVS RH - TOTVS RH (Linha Protheus) - Gestão de Pessoal - A partir da versão 12.1.2310

Causa 
Compartilhamento das tabelas SRY, SRM e RGA diferentes. 

Solução
A tabela RGA é dependente (filha) da SRY e, portanto, não pode possuir compartilhamento diferente da tabela pai. Caso isso ocorra, haverá perda de registros e quebra do vínculo entre as tabelas.

Ao acessar a rotina de Cadastro de Roteiros, o sistema busca os dados na RGA com base no roteiro posicionado e na filial da SRY. Com o compartilhamento divergente entre as tabelas, não é possível localizar os registros correspondentes, inviabilizando o funcionamento correto da rotina.
 

Exemplo de compartilhamento correto:

Atenção: A imagem acima é apenas um exemplo de que as tabelas devem possuir compartilhamento iguais. A empresa deve avaliar qual será a configuração das tabelas em seu ambiente. 

 

Saiba Mais
Documentação técnica
RH - Linha Protheus - GPE - Como recriar apenas roteiros e fórmulas do módulo 07 - Gestão de Pessoal - SIGAGPE
 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _