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Ocorrência
Ao realizar o upload de arquivos cujo nome contém caracteres especiais, como caracteres chineses (kanji/hanzi) ou outros símbolos, os caracteres são substituídos por “?” no momento em que o nome do arquivo é registrado na tabela do banco de dados.
Devido a essa substituição, ocorre um problema de referência entre o registro no banco de dados e o arquivo armazenado no volume, pois o arquivo permanece salvo no volume com o nome original e intacto, enquanto o nome gravado no banco apresenta os caracteres alterados.
Ambiente
TOTVS Fluig Plataforma - Documentos - Versão 1.8.2 ou anteriores.
Causa
O problema ocorre devido a uma configuração incorreta ou ausência de parâmetros de codificação de caracteres (encoding) na conexão entre o Fluig e o banco de dados MySQL.
Solução
Para esse comportamento, existem duas soluções viáveis.
- Realizar a atualização do banco de dados de MySQL 5.7 para MySQL 8. Após a atualização, o problema deixa de ocorrer; ou
Adicionar os parâmetros de codificação Unicode UTF-8 na URL de conexão do banco no arquivo domain.xml. Para isso, basta seguir o procedimento abaixo:
1. Acesse o arquivo [diretório de instalação do Fluig]\appserver\domain\configuration\domain.xml do servidor de aplicação.
Localize os datasources:
FluigDS
FluigDSRO
AppDS
2. Na propriedade <connection-url>, adicione os parâmetros abaixo ao final da URL:
&useUnicode=true&characterEncoding=UTF-8
Exemplo:
<connection-url>
jdbc:mysql://servidor:3306/fluig?useSSL=false&useUnicode=true&characterEncoding=UTF-8
</connection-url>
Após a aplicação da alteração, reinicie o servidor do Fluig para que a configuração entre em vigor.
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