Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Fluig - Plataforma - ECM - Erro ao subir arquivos com caracteres chineses no nome do arquivo

time.png Tempo aproximado para leitura: 00:03:00 min

Ocorrência
Ao realizar o upload de arquivos cujo nome contém caracteres especiais, como caracteres chineses (kanji/hanzi) ou outros símbolos, os caracteres são substituídos por “?” no momento em que o nome do arquivo é registrado na tabela do banco de dados.

Devido a essa substituição, ocorre um problema de referência entre o registro no banco de dados e o arquivo armazenado no volume, pois o arquivo permanece salvo no volume com o nome original e intacto, enquanto o nome gravado no banco apresenta os caracteres alterados.

Ambiente
TOTVS Fluig Plataforma - Documentos - Versão 1.8.2 ou anteriores.

Causa 
O problema ocorre devido a uma configuração incorreta ou ausência de parâmetros de codificação de caracteres (encoding) na conexão entre o Fluig e o banco de dados MySQL.

Solução
Para esse comportamento, existem duas soluções viáveis.

  1. Realizar a atualização do banco de dados de MySQL 5.7 para MySQL 8. Após a atualização, o problema deixa de ocorrer; ou
  2. Adicionar os parâmetros de codificação Unicode UTF-8 na URL de conexão do banco no arquivo domain.xml. Para isso, basta seguir o procedimento abaixo:

    1. Acesse o arquivo [diretório de instalação do Fluig]\appserver\domain\configuration\domain.xml do servidor de aplicação.

    Localize os datasources:

    • FluigDS

    • FluigDSRO

    • AppDS

    2. Na propriedade <connection-url>, adicione os parâmetros abaixo ao final da URL:

&amp;useUnicode=true&characterEncoding=UTF-8

Exemplo:

<connection-url>
jdbc:mysql://servidor:3306/fluig?useSSL=false&amp;useUnicode=true&characterEncoding=UTF-8
</connection-url>

Após a aplicação da alteração, reinicie o servidor do Fluig para que a configuração entre em vigor.

Esse artigo foi útil?
Usuários que acharam isso útil: 1 de 1

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _