Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Fluig - Plataforma - WCM - Como resolver erro de widget duplicada durante o deploy

relogio_tempo_leitura_2.png Tempo aproximado para leitura: 00:01:30 min

Ocorrência

Ao tentar exportar uma widget para o ambiente do Fluig, ao clicar em "finalizar" a exportação, o sistema não apresenta mensagem de sucesso ou erro, e o log exibe a mensagem de erro sobre recurso duplicado:

 com.fluig.wcm.core.exception.DuplicatedResourceException: wcmapplicationcenter.duplicatedresource

Ambiente
TOTVS Fluig - Todas as versões

Causa
Esse incidente ocorre, pois a widget que está sendo criada ou atualizada possui um nome ou atributo que já existe em outra widget no sistema. A duplicidade nos seguintes campos pode causar problemas na exportação e deploy da widget: Nome do widget, Propriedade "context-root" do arquivo jboss-web.xml, Propriedade "application.code" do arquivo application.info.
 

Solução
Para solucionar essa ocorrência, realize os seguintes passos:

  1. Acesse o módulo de widgets no Fluig.
  2. Verifique se o nome da nova widget é único e não está sendo utilizado por outra widget existente.
  3. Confirme se a Propriedade "context-root" do arquivo jboss-web.xml é única e não coincide com outras widgets.
  4. Verifique a Propriedade "application.code" do arquivo application.info e assegure que também seja única.
  5. Caso algum dos campos esteja duplicado, atualize-os para valores únicos e tente realizar a exportação novamente.

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _