Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Framework - Linha Datasul - TEC - SYSTEM ERROR: Unable to convert foreign database date. Error=3 (1466)

time.png Tempo aproximado para leitura: 00:02:33 min

Ocorrência
Na execução da rotina apresenta a mensagem SYSTEM ERROR: Unable to convert foreign database date. Error=3 (1466)

Ambiente
Framework - Framework (Linha Datasul) - Oracle - Todas as versões

Causa 
Ocorre porque o DataServer do Oracle encontrou um valor de data que não consegue traduzir para o formato interno do Progress.

Solução
A Progress liberou a correção no Service Pack 12.2.13 e a na release 12.8.

OCTA-53314
INDEXED-REPOSITION optimization enabled ABL query, trying to fetch a timestamp field value by connecting to Oracle database using Oracle DataServer and that query execution fails with error message “SYSTEM ERROR: Unable to convert foreign database date. Error=3 (1466) on newly added TIMESTAMP field on oracle“.

O Service Pack está disponível para download no Portal da Progress ESD - Electronic Software Download Center

Para aplicar o Service Pack, efetue o seguinte procedimento:
1. Se o Service Pack for aplicado em uma estação, interrompa todos os serviços Progress que estiverem em execução nesta. Se for aplicado no Servidor, parar os bancos/serviços Progress que estão em execução neste Servidor;

2. Efetue um backup de segurança do diretório de instalação do Progress, principalmente o diretório properties - para Servidor de Aplicação e Banco de Dados;

3. Descompacte o Service Pack em um diretório temporário;

4. Execute a instalação através do setup.exe. No linux executar o script proinst;

5. Ao final do processo de instalação, inicie os bancos/serviços novamente.

Importante
O Service Pack Progress é cumulativo. Ao instalar o último Service Pack disponível para uma versão do Progress, todas as correções dos Service Pack anteriores também serão aplicadas.

Saiba mais
Progress 12.2.13 Issues fixed in OpenEdge 12.2.13
Progress 12.8 Issues fixed in OpenEdge 12.8
Portal da Progress ESD - Electronic Software Download Center
Informações adicionais no kbase Error 1466 when retrieving timestamp fields from Oracle with negative year value

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _