Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Framework - Framework (Linha Protheus) - Mensagem de uso de Libs divergentes

time.png Tempo aproximado para leitura: 00:02:00 min

Dúvida
Qual a causa da mensagem de Lib diferentes ao acessar o ambiente?

 

Ambiente
Protheus - Lib - à partir da versão 12.1.2510

 

Causa
A partir da versão 20260119 (Release 2510), o sistema só permite o acesso a um mesmo ambiente utilizando uma única versão de biblioteca (lib). Essa validação cria um bloqueio de versão (Lock) e verifica os acessos concorrentes para garantir a estabilidade e segurança do ERP, prevenindo falhas. Caso o sistema identifique que uma lib diferente está em uso, uma mensagem de aviso detalhando a divergência e a conexão será exibida.

Com essa nova validação, a aplicação de libs "a quente" (com o sistema em pleno funcionamento) não é mais possível.

Adicionalmente, a utilização da chave specialkey afeta o lock feito no ambiente. É recomendado o uso do controle de lock pelo DBAccess, pois o lock já se torna exclusivo por banco de dados, dispensando o uso da chave specialkey e evitando problemas com esta validação.

Caso seja identificado acessos com versões divergentes, será apresentado uma mensagem com o detalhamento desta divergência.

 


 

Solução

Para garantir que a nova lib seja aplicada corretamente e evitar o bloqueio por versões divergentes, siga as instruções:

  1. Realize a aplicação da nova lib em um ambiente dedicado ou de forma exclusiva (sem concorrência de acessos).

  2. Após a aplicação da nova lib, reinicie todos os servidores do ambiente para garantir que a atualização seja reconhecida e não haja conflito com as versões antigas.

  3. Certifique-se de que cada ambiente possua sua própria specialkey configurada, caso não esteja utilizando o controle de lock nativo pelo DBAccess.

 

Aviso 

A utilização da chave specialkey afeta o lock feito no ambiente, portanto é importante que cada ambiente possua sua própria specialkey configurada.

Utilizando o controle de lock pelo dbaccess o lock já é exclusivo por db, com isso a chave specialkey não é mais utilizada, o que evita problemas com essa validação.


Saiba mais

Mais informações
Mais informações sobre o lock pelo dbaccess
Bloqueio no uso de Libs distintas no mesmo ambiente

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Artigo fechado para comentários.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _