Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - Totvs Backoffice Protheus - SIGAGCT - Ao tentar visualizar ou estornar a medição ocorre Error log "variable does not exist C7_FORNECE"



time.png Tempo aproximado para leitura: 00:05:00 min

Ocorrência

Ao tentar visualizar ou estornar a medição ocorre Error log variable does not exist C7_FORNECE on {|a,b,c| FWInitCpo(a,b,c),xRet:=(POSICIONE("SA5",1,XFILIAL("SA5")+SC7->(C7_FORNECE+C7_LOJA+C7_PRODUTO),"A5_CODPRF")),FWCloseCpo(a,b,c,.T.),FwSetVarMem(a,b,xRet),xRet }

Ambiente

Cross Segmento - TOTVS Backoffice (Linha Protheus) - TOTVS Gestão de contratos - Todas as versões

Causa 

Esse incidente ocorre, pois a validação que foi informada no campo está incorreta.

Solução

1. Pesquise no erro pela validação apresentada na linha de estouro do erro conforme exemplo abaixo:

 FWInitCpo(a,b,c),xRet:=(POSICIONE("SA5",1,XFILIAL("SA5")+SC7->(C7_FORNECE+C7_LOJA+C7_PRODUTO),"A5_CODPRF")),FWCloseCpo(a,b,c,.T.),FwSetVarMem(a,b,xRet),xRet }


 

2. Na stack do erro será apresentado o nome do campo que está com erro na validação.


 

3. Realize o ajuste da validação do campo , para realização de um novo teste.Nesse exemplo o campo apresentado é customizado ,se no seu cenário o caso o campo seja customizado X3_PROPRI = U realize um teste sem o campo customizado.

Caso erro persista após validações acima , abra um ticket em um de nossos canais de atendmento com o arquivo de erro atualizado para análise de equipe de suporte.

 

Saiba Mais:

Guia de Referencia - Gestão de Contratos - Protheus 12

Artigos Materiais - Gestão de Contratos - (SIGAGCT)

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _