Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmento – Backoffice (Linha Protheus) – SIGAEST – MATA010 – Campo B5_CEME continua obrigatório mesmo após tentativa de desativação


time.png Tempo aproximado para leitura: 00:01:00 min

Ocorrência
É possível remover a obrigatoriedade de preenchimento do campo B5_CEME (tabela SB5 – Dados complementares do produto) na rotina MATA010 – Cadastro de Produtos?

Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) - Estoque/Custos - Todas as versões

Causa 
A rotina MATA010 foi reescrita em tecnologia MVC e passou a permitir a exibição de campos de tabelas relacionadas por meio do parâmetro MV_CADPROD.

Nesse novo comportamento:

  • A validação de obrigatoriedade do B5_CEME (SB5) ocorre somente quando o usuário interage com os campos da aba/quadro da SB5.

  • Caso não haja interação, a validação não é disparada.

  • O mesmo conceito se aplica às demais tabelas complementares, como SBZ e SGI.

Além disso, o campo possui regra estrutural de obrigatoriedade definida no padrão do sistema, não sendo possível remover essa obrigatoriedade nativamente via configuração.


Solução
Não é possível desativar a obrigatoriedade do campo B5_CEME por parametrização padrão.

Como alternativa, caso seja necessário um comportamento diferente, recomenda-se:

  • Utilizar pontos de entrada do MVC para implementar validações personalizadas

  • Criar regras específicas conforme a necessidade do cliente

Documentação de apoio:
https://tdn.totvs.com/pages/releaseview.action?pageId=208345968

Saiba mais:

Clique aqui e veja mais artigos sobre Cadastros e Configurações Gerais no Estoque

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _