Ocorrência
No módulo TOTVS Gestão de Estoque, Compras e Faturamento, ao consultar a NFS-e, é apresentada a seguinte mensagem de erro:
E0922 - O codigo do municipio informado na DPS para o endereco do destinatario do servico, identificado pelo CPF, nao corresponde ao municipio registrado em seus cadastros na data de competencia informada na DPS
Ambiente
Cross Segmentos - TOTVS Backoffice (Linha RM) - Documentos Eletrônicos - NFSE - A partir da 12.1.2502.
Causa
A rejeição está relacionada a uma validação cadastral realizada pela prefeitura no layout Nacional da NFS-e (DPS) conforme descrito no Manual Oficial.
(Clique aqui para baixar o manual) na linha 571 (Print) existe o seguinte relato sobre a rejeição E0922:
“Se o destinatário for identificado pelo CPF, o código do município do endereço do destinatário deve existir e corresponder ao município do seu endereço no cadastro CPF na data de competência informada na DPS.”
Quando o destinatário do serviço é pessoa física (CPF), a prefeitura realiza o cruzamento das seguintes informações:
CPF do destinatário
Município cadastrado para esse CPF na base oficial da prefeitura/Ambiente Nacional
Código do município informado no XML (tag cMun)
Data de competência da DPS (dCompet)
Para que a nota seja autorizada, a tag cMun do XML deve ser exatamente igual ao município cadastrado para o CPF na base oficial na data de competência.
Importante destacar que não são considerados:
Município de residência atual do tomador
Informações apenas declaradas no sistema
É considerado exclusivamente o município registrado oficialmente no cadastro do CPF.
Solução
Para correção, é necessário:
- Consultar o domicílio cadastral no e-CAC da Receita Federal (gov.br), ou
- Verificar cadastro municipal junto à prefeitura
- Ajustar o cMun do XML para o município cadastral correto
ou atualizar o cadastro do CPF na aba destinatário
Observação importante
Pode ocorrer de uma nota fiscal com o mesmo destinatário ser autorizada diretamente no portal da NFS-e e, ao mesmo tempo, ser rejeitada ao tentar emitir pelo RM.
Isso acontece devido a diferenças no layout e nas validações aplicadas em cada cenário:
- O XML autorizado diretamente no portal nacional utiliza um layout mais simplificado, não contemplando:
- Novos tributos (IBS/CBS)
- Grupo de destinatário dos serviços (
<dest>)
- Já o XML gerado pelo RM segue o layout mais atualizado, incluindo:
- Informações dos novos tributos (IBS/CBS)
- Grupo completo de destinatário
Com isso, ao enviar essas informações adicionais, a nota passa a ser submetida a novas validações do ambiente nacional, o que pode resultar na rejeição, mesmo que tenha sido autorizada anteriormente no portal.
Portanto, esse comportamento não caracteriza inconsistência no RM, mas sim diferença entre as regras de validação aplicadas.
Atenção
- Não é recomendado remover informações do XML (como IBS/CBS), considerando sua obrigatoriedade futura.
- O correto é atuar na causa raiz da rejeição, validando principalmente:
- Dados do destinatário
- Município informado
- Campos envolvidos nas novas regras
- Em caso de dúvidas sobre os novos tributos (IBS/CBS), orientamos a abertura de atendimento junto à equipe de Reforma Tributária RM.
Observação
Essa rejeição não caracteriza erro técnico de schema, geração de XML ou falha do sistema RM.
Trata-se de validação cadastral realizada exclusivamente pelo Ambiente Nacional.
Caso persista, é necessário acionar diretamente o Órgão municipal responsável.
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