Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Agro - PIMS CS - MDLAGNO - Err: 2289 - ORA-02289: sequence does not exist

time.png Tempo aproximado para leitura: 00:01:30 min

Ocorrência
No módulo PIMS CS - MDLAGNO, ao incluir Pré análise de solo, é apresentada a mensagem de erro Err: 2289 - ORA-02289: sequence does not exist.

SOL.png

Ambiente
TOTVS Agro – TOTVS Agro – Bioenergia – Controle Agronômico - MDLAGNO - Versão 12

Causa
Esse erro ocorre devido à falta de uma sequência numérica automática no banco de dados Oracle.

Solução
Para solucionar essa ocorrência, realize os seguintes passos:

  1. Acesse o banco de dados Oracle;
  2. Execute o seguinte comando SQL para verificar o valor máximo atual da tabela:
 
sql
select max (NO_AMOSTRA) from PRE_ANSOLO

3. Com base no resultado obtido, crie a sequência numérica com o comando abaixo, ajustando o start with conforme o resultado do select acima incrementado em 1:

 
sql
select max (NO_AMOSTRA) from PRE_ANSOLO
create sequence SEQ_PRE_ANSOLO minvalue 1 maxvalue 99999999 start with XXXX -- ajustar conforme o resultado do select acima increment by 1 cache 20;

4. Substitua XXXX pelo valor máximo encontrado + 1;

5. Execute o comando de criação da sequência;

6. Teste novamente a inclusão da Pré análise de solo no Sistema.

Importante:
Certifique-se de ter privilégios adequados no banco de dados Oracle para criar sequências antes de executar os comandos SQL.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _