Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

RH - RM - Meu RH - Erro "Foram encontrados termos não permitidos para campo de texto, favor revisar os dados inseridos!"

time.png Tempo aproximado para leitura: 00:01:35 min

Ocorrência
Ao tentar realizar login no Meu RH, é apresentado a mensagem de erro: "Foram encontrados termos não permitidos para campo de texto, favor revisar os dados inseridos!"

erro_app.jpeg

Ambiente
TOTVS RH - TOTVS RH (Linha RM) - Meu RH – Todas as versões

Causa 
Este erro ocorre devido a uma medida de segurança que impede o uso do caractere ponto e vírgula (;)  na senha, com o objetivo de prevenir tentativas de ataque do tipo SQL Injection.


Solução
Para solucionar este erro, atualize a senha do usuário removendo o caractere ponto e vírgula (;) e utilize outro caractere especial permitido, como @, &, !, entre outros.

Caso essa mensagem de erro seja apresentada em outras rotinas que contenham campos de texto, como, por exemplo, solicitação de abono, inclusão de batidas manuais ou atestados, é necessário revisar o conteúdo informado e verificar se não está sendo utilizada alguma palavra reservada que corresponda a comandos SQL, como GO, UPDATE, INSERT, entre outras.

Para conhecer todas as palavras reservadas, consulte a documentação oficial:

Palavras-chave reservadas SQL Server

Palavras-chave reservadas Oracle

 

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _