Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - Backoffice RM - Integração - EAI - Erro ao buscar dlls de adapters no diretório

time.pngTempo aproximado para leitura: 00:01:30 min

Ocorrência
Erro no momento de realizar integração RM x Protheus.

Exemplo Erro:
Erro ao buscar dlls de adapters no diretório: "C:\totvs\CorporeRM\RM.Net\"! O acesso ao caminho 'C:\totvs\CorporeRM\RM.Net\RM.exe.WebView2\EBWebView\AutoLaunchProtocolsComponent\1.0.0.10' foi negado. 
Identificador da Mensagem Unica na Fila-UUID: 9a99a99a-9aa9-999a-a9aa-999a999a99aa




Ambiente
Cross Segmentos - Backoffice RM - Integração - Todas as versões.

Causa
Essa inconsistência geralmente ocorre quando o usuário responsável por iniciar o serviço do RM não possui as permissões adequadas na pasta de instalação. 

Solução

Para resolver, é necessário garantir que esse usuário tenha acesso completo ao diretório.

Verificando o usuário do RM Host e ajustando permissões:

  1. Acesse o diretório:
    UNIDADE:\totvs\CorporeRM\RM.Net
     
  2. Localize o aplicativo:
    RM.Host.ServiceManager.exe
     
  3. Clique com o botão direito e selecione "Executar como administrador".
     
  4. Uma vez aberto, verifique qual usuário está sendo utilizado para iniciar o serviço

    Obs.: Por padrão, o usuário utilizado é o NETWORK SERVICE.
     

  5. Após identificar o usuário, atribua as seguintes permissões na pasta de instalação (por padrão localizada em C:\totvs\CorporeRM):
    • Permissão Total (Leitura e Gravação)


       
  6. Finalizado o processo, execute novamente a integração e verifique se o erro foi resolvido.
     
     

Mais informações:

Framework - Linha RM - Frame - Configurações para iniciar o Host

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _