Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmento - Backoffice (Linha Protheus) - SIGAEST - MATA190 - errorlog: type mismatch in array subscriptor - expected N->C on BACKOFFICE.STOCK.CALCULATIONCOST.CALCULATIONNFETRBGEN (BACKOFFICE.STOCK.CALCULATIONCOST.TLPP)

O erro "type mismatch in array subscriptor" ocorre na rotina Refaz Custo de entrada devido a inconsistências na regra tributária da Substituição Tributária (ST) da nota fiscal de entrada. Isso pode ser causado por regra inexistente, parâmetro incorreto ou divergência em campos tributários. A solução envolve gerar o errorlog, identificar o ID do configurador de tributo (CIDTRIB), localizar a nota fiscal envolvida, validar a regra tributária e corrigir a configuração para refazer a nota fiscal corretamente.

time.png Tempo aproximado para leitura: 00:01:00 min

Ocorrência

Ao executar a rotina Refaz Custo de entrada é gerado o errorlog: "type mismatch in array subscriptor - expected N->C on BACKOFFICE.STOCK.CALCULATIONCOST.CALCULATIONNFETRBGEN(BACKOFFICE.STOCK.CALCULATIONCOST.TLPP)", como posso identificar e corrigir? 

Ambiente

Cross Segmento - TOTVS Backoffice (Linha Protheus) - Estoque/Custos - Todas as versões.

Causa 

Esse incidente ocorre quando há inconsistência na regra tributária utilizada no cálculo da Substituição Tributária (ST) da nota fiscal de entrada.

O erro “type mismatch in array subscriptor – expected N->C” indica que, durante o processamento do cálculo de custo, o sistema tentou acessar uma posição do array relacionada ao CIDTRIB (ID do configurador de tributo) com um tipo diferente do esperado (numérico vs caracter).
Isso geralmente ocorre devido a:

  • Regra de cálculo inexistente ou excluída da base;

  • Parâmetro tributário incorreto ou incompleto no configurador de tributos;

  • Divergência entre D1_IDTRIB, F2D_IDREL e o campo F2D_TRIB, causando falha ao gerar a estrutura de cálculo usada na rotina de custo.
     

Solução 

1. Gerar o errorlog completo:

Quando o erro aparecer em tela, salve o conteúdo exibido em um bloco de notas para análise.

 

2. Localizar o STACK do processo: 
No arquivo errorlog, procure pelo trecho:  “BACKOFFICE.STOCK.CALCULATIONCOST.CALCULATIONNFETRBGEN”. Nesse ponto será possível identificar o ID do configurador de tributo (CIDTRIB) que não foi carregado corretamente durante o cálculo do custo.

 

3. Identificar a nota fiscal envolvida:
Localize o campo D1_DOC no errorlog para descobrir qual é a NF de entrada associada ao CIDTRIB que gerou a falha.

 

4. Validar a regra tributária utilizada na NF:
De posse do número da nota, consulte o campo D1_IDTRIB e verifique o relacionamento com o campo F2D_IDREL, conforme documentação:

Cross Segmento - Backoffice (Linha Protheus) - SIGAEST - Como identificar impostos do Configurador de Tributos nas Notas Fiscais?

 

5. Verificar a configuração no F2D:
No registro F2D correspondente, valide o campo F2D_TRIB, confirmando se a regra tributária está ativa, íntegra e corretamente configurada.
→ Caso a regra esteja incorreta, incompleta ou inexistente na base, ou registros DELETADOS, o errorlog pode ser gerado.

 

6. Corrigir e refazer a nota:
Após identificar o problema na regra tributária, ajuste o configurador conforme necessário. Em seguida, cancele e refaça a NF de entrada para permitir o cálculo correto do custo.

 

Saiba mais:

Clique aqui e veja mais artigos sobre Custos no Estoque

SIGAEST - Como configurar o custo de entrada com impostos na TES?

Cross Segmento - Backoffice (Linha Protheus) - SIGAEST - Como identificar impostos do Configurador de Tributos nas Notas Fiscais?

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _