Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

RH - RM - Meu RH - Documento da assinatura eletrônica exibido em branco no Meu RH

time.png Tempo aproximado para leitura: 00:01:27 min

Ocorrência
Ao acessar no Meu RH a página de visualização do documento / relatório e inserir o código de acesso, não é exibido nenhuma informação no documento. Em vez disso, é apresentada apenas uma tela em branco no local onde o conteúdo deveria ser carregado.

image-2025-4-8_15-53-17.png


Ambiente
TOTVS RH - TOTVS RH (Linha RM) - Meu RH - A partir da versão 12.1.2406

Causa 
O problema ocorre pois o navegador está tentando carregar um arquivo JavaScript como um module script (type="module"), mas o servidor está retornando o MIME type incorreto (application/octet-stream) ao invés de application/javascript ou text/javascript. Isso quebra a execução do módulo e impede a renderização do PDF.


Solução
É necessário garantir que o IIS esteja configurado para servir arquivos .mjs e .ftl com o MIME type correto. Acesse o diretório C:\TOTVS\CorporeRM\FrameHTML, edite o arquivo Web.config e adicione as seguintes tags no <staticContent>:

<mimeMap fileExtension=".mjs" mimeType="text/javascript" />
<mimeMap fileExtension=".ftl" mimeType="text/plain" />

 

Saiba mais

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _