Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

RH - RM - FOP - Erro Violação de chave estrangeira na criação de usuários para acesso ao RM Portal

time.png Tempo aproximado para leitura: 00:01:48 min

Ocorrência
Ao executar a rotina de inclusão de usuários para Acesso ao RM Portal, é apresentado a mensagem de erro "Violação de chave estrangeira".



Ambiente
TOTVS RH - TOTVS RH (Linha RM) - Meu RH - Todas as versões

Causa 
Esse erro ocorre, quando a parametrização global de segurança do sistema, está habilitado para validar a complexidade de senha na criação do usuário.


Solução
A rotina de criação de usuários considera apenas duas opções de senha padrão: CPF ou último nome do colaborador em letras maiúsculas. Caso a política de senha configurada nos Parâmetros Globais exija critérios que não são atendidos por essa rotina — como, por exemplo, o uso de caracteres especiais —, será necessário acessar o módulo Serviços Globais > Ambiente > Parâmetros Globais > Segurança e desmarcar o parâmetro “Validar complexidade de senha no cadastro” para permitir a criação do usuário. 

Observação: Ao desmarcar este parâmetro, a validação de complexidade da senha será desconsiderada apenas no momento da criação do usuário. Nas alterações posteriores de senha, continuará sendo obrigatório que a nova senha atenda aos requisitos definidos na política de segurança.
Como boa prática, durante a criação do usuário, é possível marcar o parâmetro “Usuário deve alterar senha no próximo login”, garantindo que a senha seja alterada no primeiro acesso.
 

Saiba mais:

RH - RM - FOP - Como criar usuário de acesso ao RM Portal para funcionários

Framework - Linha RM - Frame - Validar complexidade de senha no cadastro

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _