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Cross Segmento - Backoffice (Linha Protheus) - SIGAEST - Perguntas da rotina (SX1) não aparecem no Cadastro do Schedule

Ao cadastrar o Schedule de uma rotina no SIGAEST, pode aparecer a mensagem "Operação inválida para o tipo de rotina informada no agendamento (processo especial)". Isso ocorre porque algumas rotinas dependem da tabela SXD para definir perguntas no "Editar Parâmetros", enquanto outras usam a função Scheddef. Verifique se a rotina está na tabela SXD com grupo de perguntas registrado; caso contrário, pode usar Scheddef, que pode ter restrições para edição via Schedule.

 

time.png Tempo aproximado para leitura: 00:03:00 min

Ocorrência

Ao cadastrar o Schedule de uma rotina e clicar no botão "Editar Parâmetros" é exibida a mensagem:

Operação inválida
Operação inválida para o tipo de rotina informada no agendamento (processo especial).

 

SCHEDUL.jpg


Ambiente

Cross Segmento - Backoffice (Linha Protheus) - SIGAEST - todas as versões


Causa 

Algumas rotinas do sistema dependem do registro da Tabela SXD para identificar quais perguntas poderão ser preenchidas ao clicar no botão "Editar Parâmetros" no cadastro do Schedule, enquanto outras utilizam a função "Scheddef".

Caso a rotina utilize a Tabela SXD, na tabela estará a informação de qual grupo de perguntas (SX1) será apresentado no Schedule:

SXD.png
 

Solução

Verifique se a rotina que está cadastrando existe na tabela SXD e se ela possui um Grupo de Perguntas (SX1) registrado no campo "XD_PERGUNT", caso não exista, é possível que a rotina já utilize a função "Scheddef".

Caso ela já utilize a "Scheddef", a edição dos parâmetros pode ter sido bloqueada por restrição na execução da rotina via Schedule.

 

Saiba mais:

Clique aqui e veja mais artigos sobre Cadastros e Configurações no Estoque  

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