Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

RH - Linha Protheus - eSocial - TAF - Rotinas Comuns - A regra de precedência na transmissão de eventos não foi seguida. Eventos desse tipo não devem ser enviados para processamento em paralelo.


time.png Tempo aproximado para leitura: 00:01:28 min

Ocorrência
Ao enviar várias mensagens de forma simultânea para o eSocial, é retornada a seguinte mensagem: A regra de precedência na transmissão de eventos não foi seguida. Eventos desse tipo não devem ser enviados para processamento em paralelo.



Ambiente
TOTVS RH - TOTVS RH (Linha Protheus) - eSocial - TAF eSocial - Todas as versões

Causa 
A mensagem ocorre devido ao grande fluxo de envios de informações para o servidor do eSocial, ou o envio dos leiautes ocorreram de forma simultânea sem a ordem cronológica. 

Solução
eSocial controla a precedência no recebimento dos eventos por empregador e por empregado, conforme as regras definidas no leiaute, com o objetivo de garantir a integridade dos dados da empresa e dos trabalhadores.
O primeiro evento a ser transmitido deve ser sempre o S-1000 (Informações do Empregador/Contribuinte/Órgão Público). Após isso, devem ser enviados os eventos de tabelas.

Esses eventos possuem uma particularidade, quando houver necessidade de envio de mais de um lote. O usuário deve aguardar a confirmação de sucesso do processamento de um lote antes de enviar o próximo, respeitando essa sequência.

Além disso, para todos os tipos de eventos, é fundamental seguir a ordem lógica de envio, conforme as regras definidas no leiaute. No caso específico dos eventos de tabelas, a transmissão deve ocorrer lote a lote, de forma sequencial e por empregador.

 

Saiba Mais
Para saber mais consulte os links abaixo: 
eSocial | Protheus - Entregas Legais
MOS - Manual de Orientação eSocial
Perguntas Frequentes site eSocial

Para conhecimento dos eventos futuros, acessa a nossa página TOTVS Informa
selecione em categorias a área e pesquise por "Eventos"

Essa documentação também pode ser acessada 24h por dia e pelo Protheus, através da Carolina:Carolina - Assistente Virtual - Como usar a Carolina pelo ícone no produto Protheus

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _