Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Manufatura - Linha Protheus - SIGAPCP - Erro de chave duplicada na tabela SMO

time.png Tempo aproximado para leitura: 00:04:35 min

Ocorrência
Ao realizar o apontamento de produção está ocorrendo o erro Cannot insert duplicate key row in object 'dbo.SMO ou Não é possível inserir linha de chave duplicada no objeto 'dbo.SMO.

Ambiente
TOTVS Manufatura - TOTVS Manufatura (Linha Protheus) - Planejamento e Controle da Produção (SIGAPCP) - Versão 12

Causa 
A partir da release 12.1.2410 , a numeração sequencial das notas fiscais de entrada, saída e movimentos internos realizada através do parâmetro MV_DOCSEQ - Último número sequencial utilizado para movimentos foi substituída pelo controle via License Server, e essa mudança pode eventualmente resultar no erro de chave duplicada na tabela SMO - Informação Complementar Apontamento

Solução
Para solucionar essa ocorrência, realize os seguintes passos:
1. Atualize o License Server;
2. Certifique-se de que todos os RPOs - Repositórios possuem a mesma data para o fonte MATA250.PRX que deve ser igual ou superior a 19/02/2025;
3. Certifique-se de que todos os RPOs possuem a mesma data para o fonte backoffice.stock.newProxNum.tlpp que deve ser igual ou superior a 14/07/2025;
4. Certifique-se de que todos os ambientes que conectam ao mesmo banco de dados possuem a mesma chave SpecialKey configurada no appserver.ini, se realizar algum ajuste, reinicie o appserver;
5. Certifique-se de que nenhum appserver.ini possui a chave CheckSpecialKey=0 , se encontrar em algum remova e reinicie o appserver;
6. Execute a consulta abaixo no seu banco de dados, corrigindo os nomes das tabelas para os nomes corretos no seu ambiente
SELECT MAX(NUMSEQ) NUMSEQ FROM (
   SELECT MAX(D1_NUMSEQ) NUMSEQ 
   FROM SD1
   WHERE D_E_L_E_T_ = ' ' 
   UNION ALL 
   SELECT MAX(D2_NUMSEQ) NUMSEQ 
   FROM SD2
   WHERE D_E_L_E_T_ = ' ' 
   UNION ALL 
   SELECT MAX(D3_NUMSEQ) NUMSEQ 
   FROM SD3
   WHERE D_E_L_E_T_ = ' '
   UNION ALL 
   SELECT MAX(D3_IDENT) IDENT 
   FROM SD3
   WHERE D_E_L_E_T_ = ' '
   UNION ALL 
   SELECT MAX(H6_IDENT) IDENT 
   FROM SH6
   WHERE D_E_L_E_T_ = ' '
   ) MAIOR
7. Acesse o SIGACFG - Configurador e na rotina de APCFG110 - Controle de Numeração procure pela chave que contém o conteúdo da SpecialKey do seu ambiente seguida de @@@SD2. Para esse registro, no campo Número, atribua o valor obtido a partir da query executada no passo 6 somado do valor 1. 
Exemplo: se o resultado da consulta é ABCDEF, então o valor que deve ser atribuído é no campo Número é ABCDEG.

Saiba Mais
Para maios informações sobre a mudança no sequencial acesse: 
2024 - 31/10 Parâmetro MV_DOCSEQ

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _