Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - TSS Transmissão de Documentos Eletrônicos - NFSE Nacional: Falha de Schema (Element '{http://www.sped.fazenda.gov.br/nfse}cNBS': [facet 'pattern'] The value 'XXX ' is not accepted by the pattern '[0-9]{9}'.)

Ocorrência
Ao realizar a transmissão de um RPS na versão 1.01 no ambiente nacional, ocorre a falha de schema abaixo:
 

Element '{http://www.sped.fazenda.gov.br/nfse}cNBS': [facet 'pattern'] The value 'XXX' is not accepted by the pattern '[0-9]{9}'.


Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) - Todas as versões.

Causa 
Essa falha de schema ocorre pois o NBS informado no campo B5_NBS no Cadastro do Produto está no tamanho incorreto.

Por padrão deverá possuir 9 dígitos numéricos, conforme relação liberada pelo governo:
- https://www.gov.br/nfse/pt-br/biblioteca/documentacao-tecnica/documentacao-atual 
(Anexos de Dominío > ANEXO_B-NBS2-LISTA_SERVICO_NACIONAL-SNNFSe-v1.00-2025121).

Lembrando que é de total responsabilidade do prestador saber o conteúdo (NBS) correto, qualquer dúvida o governo deverá ser acionado.

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Artigo fechado para comentários.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _