Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - Backoffice Protheus - Automação Fiscal - THREAD ERROR type mismatch on compare on MONITORUPD(AUTONFEBUSINESS.PRW)


Ocorrência:
No módulo Faturamento, ao tentar realizar o monitoramento na rotina Monitor/Faixa é retornado errolog.

THREAD ERROR: type mismatch on compare  on MONITORUPD(AUTONFEBUSINESS.PRW) 25/11/2025 00:00:50 line : 481


Ambiente:
Cross Segmento - TOTVS BackOffice (Linha Protheus) - A partir da versão 12.1.2310

Causa:  
O incidente ocorre devido ao conteúdo do campo "TIPO" está divergente no parâmetro MV_TAFISCH no ambiente, este parâmetro deve ser do tipo caractere "C" o erro ocorre quando está como Lógico "L".


Solução:


 1° Aplique atualização completa do Módulo 84 (TAF).
 
12.1.2310: https://suporte.totvs.com/portal/p/10098/download#detail/1126399 (Somente ambiente com garantia estendida).
12.1.2410: https://suporte.totvs.com/portal/p/10098/download?e=1174332 

12.1.2510: https://suporte.totvs.com/portal/p/10098/download?e=1228187
 
  2° Execute o UPDTAF e UPDDISTR,

Cross Segmentos - Backoffice Protheus - Automação Fiscal - Como executar o UPDTAF

 
IMPORTANTE: O conteúdo do campo TIPO do parâmetro MV_TAFISCH, somente vai ser corrigido para caractere (C) após execução do UPDTAF.

Realize o teste no ambiente de homologação e após correção replique na sua produção.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _