Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - Backoffice Protheus - Automação Fiscal - Arq. Magnéticos - Monitor de Eventos - Foi detectada uma divergência no tamanho dos campos (T7A_CHVELE e C20_CHVELE)

Ocorrência
Mensagem de alerta ''Foi detectada uma divergência no tamanho dos campos (T7A_CHVELE e C20_CHVELE)'' ao abrir a rotina TAFA635 (Monitor de Eventos).

 

PRINT 1.png

Ambiente
Microsiga Protheus – TAF – versão 12.1.2410 e inferior.

 

Causa
Erro ocorre devido a diferença de campos da tabela T7A e da tabela C20, onde por padrão os campos são criados como T7A_CHVELE com tamanho 44, e C20_CHVELE com tamanho 60.

Solução
Acesse o SIGACFG e vá no seguinte caminho Base de Dados>Dicionário>Base de dados.

PRINT 2.png


Posteriormente, vá até a lupa e pesquisa a tabela T7A.

PRINT 3.png
 

Após isso, clique para editar a tabela (ícone do lápis).

PRINT 4.png
 

Clique para editar novamente com o campo selecionado, e altere o tamanho para 60.

PRINT 5.png
 

Posteriormente, clique para Sair (ícone da porta), e salve a alteração (ícone do disquete).

PRINT 6.png
 

Avance as telas e valide que o campo foi alterado.

PRINT 8.png

 

Validando a mensagem que foi alterado com sucesso, basta finalizar o processo.

 

Posteriormente, saia do Configurador e acesso o TAF onde o erro inicial não deverá persistir.

Procedimento não deve ser realizado a parti da release 2510. 

IMPORTANTE: É NECESSÁRIO QUE O PROCESSO EXECUTADO SEJA FEITO COM AMBIENTE DE MANEIRA EXCLUSIVA (SEM NENHUM USUÁRIO LOGADO NO AMBIENTE).

Documentação complementar:

https://tdn.totvs.com/display/public/TAF/Monitor+de+Eventos+-+TAF+-+P12

 

 

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _