Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - Backoffice Protheus - SIGAFAT - InterFunctionCall: cannot find function CBOTPCOMPL

time.png Tempo aproximado para leitura: 00:02:00 min

Ocorrência
Como corrigir os erros InterFunctionCall: cannot find function CBOTPCOMPL e Help:NOFUNCW - Opção não disponível no Protheus Função: CBOTCOMPL Called By X3CBOX?

Ambiente
Cross Segmentos - Backoffice Protheus - SIGAFAT - Todas as versões.


Causa
O erro ocorre devido a ausência de uma função presente no fonte MATA600.PRW (Nota de Débito), para corrigir é necessário aplicar o pacote de expedição contínua abaixo:
 

Obs.: Caso já tenha aplicado o pacote e ainda ocorra o erro, isso significa que houve algum erro na atualização, será necessário reaplicar o pacote atualizando novamente os fonte e rodando o UPDDISTR.

Solução

Segue passo a passo:

1 - Aplique o pacote de 'Expedição Contínua' de dezembro/2025 conforme sua release: Pacotes de Atualização - Faturamento

Exemplo: 


2 - Atualize os fontes e aplique o dicionário contido na pasta "sdf": Abra a pasta SDF > Abra a pasta "bra" > Copie todas as pastas e cole (substituindo) dentro da pasta "" do ambiente Protheus "protheus > protheus_data > systemload".

3 - Rode o UPDDISTR para compatibilizar os dicionários e as tabelas necessárias.
 

Observações
Caso o ambiente seja Cloud, recomendamos seguir o processo presente na documentação da equipe: CLOUD - MP - Aplicar Pacote (Patch). Se surgir alguma dúvida/impeditivo sobre o processo documentado, recomendamos abrir um chat/ticket com o time Cloud para auxiliarem na aplicação do pacote.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Artigo fechado para comentários.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _