Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - Backoffice Linha Protheus - SIGAGCT - Tentativa de reservar registro no Alias em EOF Stack de chamadas em MSRLOCK.eof

time.png Tempo aproximado para leitura: 00:05:00 min

Ocorrência

Ao realizar um processo no Gestão de Contratos ocorre a mensagem: 

"Tentativa de reservar registro no Alias "XXX" em EOF Stack de chamadas em MSROCK.eof .Tenta novamente? Essa mensagem será fechada em 5 segundos"

 

Ambiente

Cross Segmento - Backoffice Linha Protheus – Gestão de Contratos – A partir da versão 12

 

Causa 

A mensagem referente a EOF Stack em MSRLOCK indica que o registro em questão está reservado por outro processo.

Esta mensagem pode acontecer em duas situações:

1 -  o uso do registro por outro usuário;

2 - uma customização que iniciou o tratamento que provocou "unlock" travamento do registro.

 

Solução:

Nestes casos pode-se realizar os seguintes procedimentos:

- Reiniciar o servidor (parando os serviços do DBAccess, Banco de dados e demais serviços do Protheus) e realizar novos testes.

O reinício dos serviço também do Banco de Dados, é devido, pois já foram verificadas situações de registros presos somente na camada do Banco de Dados, e assim reiniciando este serviço do BD neste caso a questão pode ser solucionada.

 

Se erro persistir, seguir o segundo procedimento:

- Verificar se o arquivo MSRLOCK.EOF gravado na pasta system, se existe alguma customização no sistema que envolva o ALIAS da tabela apresentado na mensagem, caso exista, efetue um teste com a customização desativada, você pode identificar se tem uma customização no processamento, se existir uma linha iniciando com U_ na instrução do arquivo, então refazer o teste novamente de processamento (Como desativar).

 

Saiba Mais:

FAT0240 EOF Stack de chamadas em MSRLOCK.eof Controle de transaçoes Habilitado

Controle de Transação - MV_TTS

Cross Segmentos - Totvs Backoffice Protheus - SIGAGCT - Documentação Gestão de Contratos do TDN 

Guia de Referencia - Gestão de Contratos - Protheus 12

FAQs - Gestão de Contratos 

Artigos Materiais - Gestão de Contratos - (SIGAGCT)

 

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _