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Ocorrência
No Pedido de Vendas que possui contrato de parceria, ao alterar a condição de pagamento, alguns campos do pedido de venda são limpos/zerados.
Ambiente
Cross Segmentos - Backoffice Protheus - SIGAFAT - Todas as versões
Causa
Caso seja informada uma condição de pagamento que não esteja vinculada a um contrato de parceria no Pedido de Vendas (MATA410) gerado a partir desse contrato, os campos "Preço Unitário (C6_PRCVEN)", "Tipo Saída (C6_TES)", "No. Contrato (C6_CONTRAT)" e "Item Contr (C6_ITEMCON)" deverão ser limpos automaticamente.
Essa verificação é realizada pelo gatilho do campo Condição de Pagamento (C5_CONDPAG), por meio das validações da rotina, que identifica se a condição de pagamento informada possui vínculo com algum contrato de parceria.
O parâmetro MV_PRCCTR, responsável pela captação do Contrato de Parceria, quando configurado para ".T.", faz com que o sistema entenda que o pedido de venda é um novo registro, resultando na limpeza dos campos associados. Esse comportamento é desenvolvido para assegurar que o Pedido respeite as informações do Cliente X Contrato de Parceria.
Solução
Para solucionar essa ocorrência, basta desativar o parâmetro MV_PRCCTR
- Acesse o módulo de Configurador (SIGACFG) no Protheus;
- Localize o parâmetro MV_PRCCTR;
- Altere o parâmetro MV_PRCCTR para .F.;
- Salve as configurações;
- Teste a alteração do pedido de venda novamente para verificar se os campos permanecem preenchidos.
Saiba mais:
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