Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Framework - Linha Datasul - FRW - Erro Layout selecionado não está cadastrado! na importação de um layout específico

time.png Tempo aproximado para leitura: 00:01:30 min

Ocorrência
Ao importar um layout específico via programa html.fwk-smartview-layout ocorre o erro Layout selecionado não está cadastrado! mesmo tendo feito o cadastro do layout no menu e conferido o propath da sessão e do PASOE do ambiente. 

Ambiente
Framework - Framework (Linha Datasul) - SmartView (SVW) - Todas as versões

Causa:
Essa inconsistência ocorre quando o nome do recurso criado no SmartView (seja um Relatório ou uma Visão de Dados) não coincide exatamente com o nome cadastrado no programa BAS_PROG_DTSUL.

Exemplo Prático: Imagine que no Datasul o layout foi cadastrado como rpListaEmpresa e o caminho do arquivo .sv foi apontado corretamente no propath. Contudo, ao criar o relatório no SmartView, o campo "Nome de Exibição (Padrão)" foi preenchido como: Lista de Empresa.

Mesmo que o arquivo .sv seja exportado e inserido no propath, o sistema não validará a execução devido à divergência entre os nomes.

Solução
Para resolver o problema, você pode seguir um dos dois caminhos abaixo:

Opção 1: Ajustar o cadastro no Datasul
Criar um novo cadastro de recurso no BAS_PROG_DTSUL, utilizando exatamente o mesmo nome definido no SmartView (lembrando que o código do programa não tem espaços em branco). Depois, basta apontar o caminho do arquivo .sv atual no propath.

Opção 2: Ajustar o recurso no SmartView
Criar uma cópia do recurso atual dentro do SmartView e renomeá-lo com o mesmo nome que já está cadastrado no BAS_PROG_DTSUL.

Nota: Escolhendo esse caminho, será necessário exportar novamente o arquivo .sv gerado e atualizar o novo arquivo no propath do produto.

Exemplo de como deverá ficar o cadastro dentro do SmartView x Datasul.

cadastroRecurso.jpg





 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _