Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Framework - Linha Datasul - FRW - Erro Layout selecionado não está cadastrado! na importação de um layout específico

time.png Tempo aproximado para leitura: 00:01:30 min

Ocorrência
Ao importar um layout específico via programa html.fwk-smartview-layout ocorre o erro Layout selecionado não está cadastrado! mesmo tendo feito o cadastro do layout no menu e conferido o propath da sessão e do PASOE do ambiente. 

Ambiente
Framework - Framework (Linha Datasul) - SmartView (SVW) - Todas as versões

Causa 
Este problema ocorre quando é criado um relatório no Smartview com um nome e depois de exportado o recurso é renomeado para um nome diferente e cadastro no menu do Datasul com esse mesmo nome no qual renomeou e não efetivamente com o nome no qual ele foi criado no Smartview

Exemplo: No Smartview o relatório específico foi criado como rpTeste.sv mas depois de exportado renomeou para rpPedido.sv e utiliza este nome para cadastrar o recurso no Datasul. 

Internamente no recurso gerado pelo Smartview (.sv ou .treports) fica uma referência ao nome criado pela ferramenta, então quando se muda o nome depois de exportado ou gerado, mesmo o objeto físico e do cadastro estando iguais pode gerar a inconsistência. 
 
Solução
Para solucionar essa ocorrência, criar um novo relatório selecionando o objeto de negócio e depois de exportado, renomear para o mesmo nome com o qual foi criado no Smartview e fazer o cadastro seguindo este mesmo nome. Não é simplesmente mudar o nome depois de exportado e cadastrar conforme o nome que mudou, ele precisa ser cadastrado exatamente com o mesmo nome criado no Smartview

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _