Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - Totvs Backoffice Protheus - SIGAGCT - Help AJUDA:OBRIGAT Um ou mais campos obrigatórios não foram preenchidos no encerramento da medição



time.png Tempo aproximado para leitura: 00:05:00 min

Ocorrência
Help AJUDA:OBRIGAT
Um ou mais campos obrigatórios não foram preenchidos. xxxxxxxxxxxxxxxxxx -> xxxxxxxxxx
Nome do Campo 


Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) - TOTVS Gestão de Contratos - Todas as versões


Causa 
Esse incidente normalmente ocorre quando é configurado como obrigatório um dos campos da tabela de Pedido de compra(SC7) ou Pedido de Venda(SC5/SC6), que são gerados no encerramento da medição. No entanto o campo referente não foi preenchido na medição, não sendo levada a informação para o pedido, impedindo a gravação do campo no pedido, e resultando na exibição do Help mencionado.


Solução
Para solucionar essa ocorrência, realize os seguintes passos:
1. Caso no encerramento da Medição seja gerado um Pedido de Compra, localize no configurador do sistema o campo da rotina de Pedido de compras (SC7) indicado na mensagem do Help. Em seguida, retire a obrigatoriedade deste campo no configurador do sistema, salve as alterações e realize um novo teste.

Outra possibilidade é preencher, na medição, o campo correspondente ao indicado na mensagem de help (caso exista). Dessa forma, o valor será gravado corretamente no Pedido, evitando que o help seja exibido.


2. Caso no encerramento da Medição seja gerado um Pedido de Venda localize no configurador do sistema o campo indicado na mensagem do Help , na tabela (SC5/SC6). Em seguida, retire a obrigatoriedade deste campo no  configurador do sistema, salve as alterações e realize um novo teste.

Outra possibilidade é preencher, na medição, o campo correspondente ao indicado na mensagem de help (caso exista). Dessa forma, o valor será gravado corretamente no Pedido, evitando que o help seja exibido.

 

Por padrão, o sistema preenche apenas os campos do Pedido que são obrigatórios no padrão original do sistema.

Demais campos da tabela SC7 ou SC5/SC6 de Pedido que foram colocados como obrigatório além dos que já são poe padrão, para seus preenchimentos na geração do Pedido pelo Medição, podem ser preenchidos através de customização de Ponto de Entrada.

Abaixo segue artigo disponível com os pontos de entrada da Rotina de medição contendo o que pode ser utilizado para preenchimento de campos nos Pedidos gerados:

Cross Segmentos - Totvs Backoffice Protheus - SIGAGCT - Pontos de entrada para rotina de Medição

- CN121PED - DT_PE_CN121PED_Tratamento_especifico_antes_da_geração_do_pedido_de_compra

 

 

 

Saiba Mais:

Cross Segmentos - Totvs Backoffice Protheus - SIGAGCT - Pontos de entrada para rotina de Medição

CN121PED - DT_PE_CN121PED_Tratamento_especifico_antes_da_geração_do_pedido_de_compra

Artigos Materiais - Gestão de Contratos - (SIGAGCT)
 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _