Ocorrência
Ao tentar realizar a transmissão de cancelamento de um RPS, a nota não é apresentada no GRID para que seja selecionada:
Ambiente
Cross Segmentos - TOTVS Backoffice Protheus - TOTVS Doc. Eletrônicos - Todas as versões.
Causa
Esse problema geralmente ocorre por alguns motivos principais:
1. A nota não foi devidamente monitorada após autorização, logo, os campos na tabela SF3 não foram atualizados e no filtro realizado pela rotina acaba falhando;
2. Há duplicidade de registros na SF3 para o mesmo RPS x SÉRIE x ESPÉCIE;
3. O documento de saída não foi excluído;
4. Está tentando ser realizado o cancelamento de uma nota que não foi previamente autorizada.
Solução
Ainda em relação aos itens citados acima, segue orientações:
1. Acessar a rotina e realizar o monitoramento (Outras Ações -> Monitor), mesmo que a nota não seja mais exibida na tela do grid (comportamento comum pelo fato dela ter tido o documento excluído).

Após monitorar, os campos da SF3 serão populados da seguinte maneira e a nota será apresentada corretamente no filtro após clicar em 'Trans. Canc', desde que a data informada no range contemple a data de exclusão do documento (campo F3_DTCANC):
F3_CODRSEF = S
F3_CODRET = 111
F3_OBSERV = 'NF CANCELADA'
F3_DTCANC = 'AAAAMMDD'

2. Deverá conter apenas um registro ativo por nota na SF3, e caso haja duplicidade, deverá verificar junto a equipe Fiscal para a correta configuração. (Exemplo: TES estar calculando ICMS para Nota de Serviço é uma das possibilidades).
3. O procedimento deve ser executado conforme o material cancelamento de um RPS, isso inclui a exclusão do documento de saída.
4. Nesse caso não será possível de fato realizar a transmissão de cancelamento pois a nota não foi enviada para a prefeitura, basta apenas realizar a correção do documento, corrigir e prepara-lo para transmitir novamente.
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