Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmento - Backoffice Linha Protheus - SIGAFIN - FINA050 - Inclusão do Código de Barra - HELP INVCDBAR


Ocorrência
No módulo Financeiro FINA050, ao tentar realizar o incluir código de barras é informado que o código de barras é invalido. 
mceclip0.png

Ambiente
Cross Segmento - Backoffice Linha Protheus – Financeiro – FINA050 - Todas versões

Causa
Esse incidente informado INVCDBAR, ocorre devido a não ser validado o código informado campo E2_CODBAR

Solução
Para que o erro não ocorra deve-se carregar os campos corretamente, ou seja código de barras E2_CODBAR e linha digitável no E2_LINDIG. 

Caso tenho duvida se trata de linha digitavel ou Código de barras, poderá ser verificado pela quantidade de caracteres.  Os dados da Linha Digitável representam o conteúdo do Código de Barras dispostos em outra ordem e acrescidos de dígitos verificadores nos 3 primeiros campos onde:

E2_CODBAR Código de Barras tem 44 dígitos 

E2_LINDIG  Linha Digitável tem 47 dígitos

 

mceclip0.png

 

E ainda pode ser utilizado na rotina FINA050 / FINA750 - Outras Ações - Código de Barras, onde inserindo código valido o sistema automaticamente distribui para o campo correto (E2_CODBAR e E2_LINDIG )

mceclip1.png

 

Essa função já esta disponível desde Fevereiro/2021, caso não apareça a opção ( Outras Ações - Código de Barra) será necessário do atualização da rotina (FINA050) e do dicionário de dados  na qual disponibilizadas novas funcionalidades entre elas, preenchimento automático (Outras Ações - Código de Barra )

Para habilitar essa funcionalidade será necessário além do pacote aplicado  (ATUALIZACAO_FIN_EXPEDICAO_CONTINUA) também o dicionário contido nesse pacote ( SXSBRA.TXT ) através do UPDDISTR.

 

Importante
Pacote disponível para habilitação das funcionalidade mencionadas FINANCEIRO

ACUMULADO - 12.1.27 - https://suporte.totvs.com/portal/p/10098/download?e=954746
ACUMULADO - 12.1.33 https://suporte.totvs.com/portal/p/10098/download?e=1039087



Saiba mais
DESCRICAO_CAMPOS_E2_LINDIG_E_E2_CODBAR

 

Esse artigo foi útil?
Usuários que acharam isso útil: 1 de 1

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _