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RH - RM - PTO - Erro ao importar batidas na integração com a Carol/Clock In.


time.png Tempo aproximado para leitura: 00:01:30 min

Dúvida

Ao executar o processo de importação automática de batidas utilizando a integração com a Carol é apresentado no log técnico Carol o erro :

******* Início do processo de autenticação *******

Recuperando dados de tenant para autenticação.
Dados de tenant recuperados com sucesso.
- grant_type: password
- connectorId: clockinmobile
- subdomain: nomeempresa
- orgSubdomain: nomeempresa
Definindo parametros para autenticação.
- urlBase: https://nomeempresa.carol.ai/api/v2/
- urlRequisicao: oauth2/token
Iniciando geração de token de autenticação.
Iniciando requisição http assíncrona.
Aguardando execução da requisição http.
e.Message: One or more errors occurred.
e.InnerException: An error occurred while sending the request.

******* Fim do processo de autenticação *******


Ambiente
RH - RH (Linha RM) - TOTVS Automação de Ponto - A partir da versão 12.1.28

Causa
Esse incidente ocorre, quando não é possivel efetuar a autenticação na plataforma Carol, devido ao usuário e senha ter sofrido alterações ou quando existe bloqueio de rede.

Solução
Para solucionar essa ocorrência, realize os seguintes passos:

1. Efetuar o login na URL apresentada no log (https://nomeempresa.carol.ai/)  com o mesmo usuário e senha configurado no parametrizador e validar se ele consegue visualizar as  batidas no Clock In.  O acesso pode ser efetuado direto pelo navegador.

mceclip0.png

mceclip2.png

2. Se existir alguma configuração de proxy definida no menu : Ambiente | parâmetros | parâmetros globais etapa Google,  nas regras do proxy deve ser liberada a conexão com a Url da Carol.

mceclip3.png

3.  Acesse os servidores/maquinas envolvidos no ambiente Totvs RM, exemplo: servidor que tem o banco de dados instalado, servidor de Job, servidor de app.
Estes servidores também devem ter o acesso a URL. Acesse os servidores e tente conectar na URL da Carol direto pelo navegador. 

Para verificar se o ambiente da empresa é Local ou N camadas acesse: RM - Frame - Diferença entre instalação local e 3/N camadas.

4. Avalie se houve alterações de Firewall em sua infra, ou mesmo se o Antivírus está bloqueando o acesso. Pois pode haver impacto na integração. Efetue os ajustes se necessário.

5. Verifique se as URL's e portas contidas no artigo abaixo estão liberadas para a integração:

Requisitos de Infraestrutura


Saiba Mais:

Para mais informações da configuração integração RM X Carol acesse : Integração RM X Carol - Importação de Batidas.

 

 

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