Ocorrência
Ao incluir o pedido de vendas gera o help OMSTABPRC1, como solucionar?
Ambiente
Cross Segmentos - TOTVS Backoffice (Linha Protheus) - Faturamento - A partir da versão 11.80
Causa
Esta mensagem indica que foi informada uma tabela de preço no Pedido de Vendas (MATA410) seja inclusão direta ou efetivação de um orçamento e a vigência da tabela utilizada esta fora de um prazo válido, sendo necessário ajustar para incluir/alterar o pedido.
Solução
Avalie se a DATABASE (data informada no sistema, canto superior direito) está entre o intervalo da Tabela de Preços (OMSA010), mencionado nos campos Data Inicial "Data Inicial [DA0_DATDE]" e "Data Final [DA0_DATATE]", ambos campos no cabeçalho da rotina.
1 - Para não perda do histórico, é necessário criar uma nova tabela de preços com os campos DA0_DATDE e DA0_DATATE válidos para o dia do ambiente (dia atual).
2 - Caso o histórico da tabela de preços não seja importante, basta mudar os campos DA0_DATDE e DA0_DATATE para uma nova data válida que esteja suportando o dia atual do sistema.
3 - Alterar a data do sistema (DATABASE) para uma data válida entre a data dos campos DA0_DATDE e DA0_DATATE.
Saiba Mais:
Caso apresente o help OMSTABPRC2 realize o procedimento da documentação:
Help OMSTABPRC2
0 Comentários