FAQs - Suporte técnico

MP - GPE - Error log ao realizar uma transferência - array out of bounds ( 0 of XXX ) on FMONTACOLS(GPEA180.PRX)


Ocorrência

Ao tentar realizar Transferência de Funcionário, através da rotina GPEA180, é apresentado error log: "array out of bounds ( 0 of XXX ) on FMONTACOLS(GPEA180.PRX)"

Ambiente
Protheus - Gestão de Pessoal - à partir da versão 12.1.17

Causa 
Este erro ocorre quando a configuração do campo RA_POSTO está incorreta

Solução
1.
Acessar o módulo de Configurador;
2. Acessar a rotina Base de Dados/Ambiente/Bases de Dados;
3. Abrir as opções da Empresa e clicar sobre "Dicionário de Dados":
mceclip0.png

4. Clicar sobre o símbolo de Lupa nas opções da barra superior da tela;
5. No campo "Procurar Por", preencher com SRA e clicar em Buscar;
6. Sobre o item de nome SRA, clicar na opção de Alterar (símbolo de lápis sobre o papel na barra superior):
mceclip1.png

7. Abrir as opções da tabela e clicar sobre "Campos":
mceclip2.png

8. Procurar pelo campo de nome RA_POSTO e clicar para Alterar (símbolo de lápis sobre o papel na barra superior):
mceclip3.png

9. Acessar a aba "Uso" e deixar selecionado o campo "Usado", conforme abaixo e clicar em Salvar:
mceclip4.png

10. Clicar sobre a opção de Confirmar (símbolo de seta verde na barra superior):
mceclip5.png

11. Clique sobre a opção de Atualizar Base de Dados (símbolo de Disquete, na barra superior):
mceclip6.png

12. Clique em "Avançar" e "Finalizar", aceitando as mensagens que são apresentadas em tela e aguarde o processo ser finalizado;
13. Realize o processo de transferência novamente e verifique se o erro ainda ocorre.

Saiba mais:
Pacote Acumulado do RH:
MP - GPE - Como fazer o download (baixar) do pacote de expedição continua (acumulado) do modulo Gestão de Pessoal
Pacote Acumulado e-Social: https://centraldeatendimento.totvs.com/hc/pt-br/articles/360051585234 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _