Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

MP - GPE - Erro de duplicidade na tabela SR4 ao gerar a DIRF - Cannot insert duplicate key row in object 'dbo.SR4XXX' with unique index 'SRXXX_UNQ'.


Ocorrência

Ao tentar gerar a DIRF através da rotina GPEM550 gera error log de chave duplicada na SR4: "Cannot insert duplicate key row in object 'dbo.SR4XXX' with unique index 'SR4XXX_UNQ"

Ambiente
Protheus - Gestão de Pessoal - à partir da versão 12.1.17

Causa
O erro ocorre devido ao tamanho do campo R4_TIPOREN estar com tamanho incorreto

Solução
Para solucionar o problema será necessário efetuar a correção do tamanho do campo R4_TIPOREN, conforme padrão abaixo:
mceclip0.png

O tamanho deste campo foi alterado para 2 após a expedição da versão 12.1.23 e 12.1.25, por este motivo, para estas versões, é possível utilizar o Dicionário Diferencial da versão, do módulo de RH, conforme link abaixo:
MP - GPE - Como fazer o download (baixar) do pacote de expedição continua (acumulado) do modulo Gestão de Pessoal

Obs.: Por se tratar de um campo padrão do sistema, é possível que não seja possível alterar o tamanho do campo via Módulo de Configurador, sendo necessário alterar através de dicionário SX3.
Obs. II: Caso um campo seja alterado fora do Módulo de Configurador, é necessário recriar a tabela, para o campo assumir as novas propriedades.

Saiba mais
Pacote Acumulado e-Social:https://centraldeatendimento.totvs.com/hc/pt-br/articles/360051585234 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _