Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

RH - Linha Protheus - PON - Ao realizar a Leitura e Apontamento das Marcações, é gerado Error Log - argument #1 error, expected N->U, function padr on PUTMARCACOES(PONXFUN.PRX)

Ocorrência
Ao realizar a Leitura e Apontamento das Marcações através da rotina PONM010, é gerado Error Log: argument #1 error, expected N->U, function padr on PUTMARCACOES(PONXFUN.PRX)

Ambiente
TOTVS RH - TOTVS RH (Linha Protheus) - Ponto Eletrônico - Todas as versões

Causa
O erro ocorre quando os campos P8_LATITU e P8_LONGIT, ambos da tabela SP8, estão fora do dicionário/ordenação padrão da TOTVS. 

Solução
Para solucionar o erro, é necessário que os campos P8_LATITU e P8_LONGIT da tabela SP8 fiquem na estrutura do dicionário padrão conforme exemplo abaixo:
mceclip0.png
mceclip1.png

A ordem dos campos devem estar dentro do padrão da TOTVS, conforme exemplo abaixo:



Saiba Mais:
Pacote de Expedição Contínua do Gestão de Pessoal: https://centraldeatendimento.totvs.com/hc/pt-br/articles/360057829854
Manual do Ponto Eletrônico: https://tdn.totvs.com/pages/releaseview.action?pageId=630823373

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _