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RH - Linha Protheus - PON - Após reparo técnico, o Relógio de Ponto não processa a leitura das marcações


Ocorrência
Após reparo técnico, o Relógio de Ponto não processa a leitura das marcações.

Ambiente
TOTVS RH - TOTVS RH (Linha Protheus) - Ponto Eletrônico - Todas as versões

Causa 
Quando um REP passa por manutenção, o controle de NSR é reiniciado, o que faz com que o SIGAPON  não realize a leitura das marcações e as mesmas não não gravadas, pois todos os NSRs lidos no passado para aquele relógio, são gravados em tabelas do módulo.

Solução
Para solucionar esta situação, foi adicionada a opção Reiniciar NSR no menu Outras Ações ao alterar o cadastro de um relógio.

Para isto, acesse o módulo 16-Ponto Eletrônico: atualizações>cadastro do ponto>relógios
filtre o código do relógio, após alterar, clique em Outras Ações>Reiniciar NSR.
Esta opção estará disponível somente para relógios com Tipo de Arquivo T (TArquivos ASCII) e que sejam Incrementais.


Após clicar nesta opção, o sistema irá criar um novo registro na tabela de Cabeçalho de Pré-leitura - RFB, indicando que o NSR lido deste relógio foi reiniciado e deixando o campo de controle RFB_IDORG=000000000.

IMPORTANTE!

Essa opção somente deve ser utilizada em casos específicos, onde o controle de NSR do REP foi reinicializado.


Saiba Mais:
Reiniciar NSR de relógios REP
Manual do Ponto Eletrônico
Pacote de Expedição Contínua - Acumulado de RH

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2 Comentários

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    WESLEY SOUZA LARENTES

    O sistema não permite alterar o numero do relógio que já teve leitura nele.

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    WELTON LUCAS RODRIGUES

    Olá Wesley, bom dia!

    O cadastro de relógio no campo REP não permite alterações, visto que trata-se de um dispositivo com código único e quando utilizado no SIGAPON do PROTHEUS e possuí históricos de movimentações das leituras desse relógio/REP, o sistema não permite esta alteração. O correto sempre que tiver um novo relógio é efetuar um novo cadastro, o Relógio/REP anterior se manterá cadastrado para efeito de histórico.

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