FAQs - Suporte técnico

RH - Linha Protheus - PON - Após reparo técnico, o Relógio de Ponto não processa a leitura das marcações

Ocorrência
Após reparo técnico, o Relógio de Ponto não processa a leitura das marcações.

Ambiente
TOTVS RH - TOTVS RH (Linha Protheus) - Ponto Eletrônico - Todas as versões

Causa
Quando um Relógio de Ponto passa por reparo técnico, a sequência de NSR - número sequencial de registro - é reiniciada, ou seja, se o seu equipamento já estava gerando marcações com número de NSR 123456789, após o reparo, a sequência iniciará novamente a partir do número 000000001.
No passado, houveram marcações com estes números inicias de NSR que estão gravadas nas tabelas que envolvem o processo de Leitura/Apontamento, como o sistema faz essa validação e para segurança do usuário um NSR igual/maior que o atual nunca pode ter o dado sobrescrito, o sistema barra o processo de Leitura/Apontamento., 

Solução
Para solucionar este problema, o usuário deve acessar a rotina de Cadastro de Relógios, localizar o cadastro e deixar o campo REP deste relógio que passou por reparo técnico em branco. Depois, cadastre este mesmo relógio como se fosse um aparelho novo e utilizando o número de REP (o Protheus não permite dois relógios com o mesmo número de REP). Depois deste cadastro, a Leitura/Apontamento das marcações funcionará normalmente.
Não recomendamos que o registro antigo seja deletado por conta de histórico de leituras anteriores.

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