FAQs - Suporte técnico

MP - GPE - Ao visualizar Cadastros de funcionários após aplicar a Restrição de Acesso ao Grupo de Usuário 192 - Dados Pessoais é Gerado ErrorLog - array out of bounds [3] of [0] on MSMGET:NEW(MSMGETPR.PRW)


Ocorrência

Após aplicar o pacote para atender as determinações da Lei Geral de Proteção aos Dados Pessoais (LGPD) e restringir o acesso retirando o grupo de acesso 192 - Dados Pessoais ao usuário de acesso, e ao acessar a rotina de Cadastro de Funcionário, pela rotina GPEA010 e clicar no botão visualizar de qualquer funcionário é apresentado error.log abaixo:
"array out of bounds [3] of [0]  on MSMGET:NEW(MSMGETPR.PRW) 16/10/2020 20:08:47 line : 1835

[TOTVS build: 7.00.191205P-20200629]
Called from GPEA010MNT(GPEA010.PRX) 24/09/2020 10:09:32 line : 1602
Called from GPEA010VIS(GPEA010.PRX) 24/09/2020 10:09:32 line : 584
Called from FWFORMBROWSE:EXECUTE(FWFORMBROWSE.PRW) 16/10/2020 20:08:50 line : 1142
Called from

{ || OSELF:EXECUTE("GPEA010VIS",              2,            0,"VISUALIZAR",              2,"","VISUALIZAR","",              2) }

(FWFORMBROWSE.PRW) 16/10/2020 20:08:50 line : 575
Called from ::MSDIALOG:ACTIVATE
Called from FWMBROWSE:ACTIVATE(FWMBROWSE.PRW) 16/10/2020 20:08:50 line : 690
Called from GPEA010(GPEA010.PRX) 24/09/2020 10:09:32 line : 526
Called from __EXECUTE(APLIB090.PRW) 16/10/2020 20:08:47 line : 719
Called from FWPREEXECUTE(FWPREEXECUTE.PRW) 16/10/2020 20:08:50 line : 79
Called from

{ ||  FWPreExecute('Funcionários', 'GPEA010()', 1, '07', 'xxxxxxxxxx') }

(FWUIMENUL.PRW) 16/10/2020 20:08:50 line : 197
Called from ::TWINDOW:ACTIVATE
Called from MSAPP:ACTIVATE(FWAPP.PRW) 16/10/2020 20:08:50 line : 755
Called from SIGAGPE(APLIB000.PRW) 16/10/2020 20:08:47 line : 169"



Ambiente

Microsiga Protheus - Gestão de Pessoal - à partir da versão 12.1.17



Causa 
Este erro ocorre devido à fontes desatualizados



Solução
1. 
Necessário aplicar o seguinte pacote de correção:
Pacote Acumulado do RH: https://centraldeatendimento.totvs.com/hc/pt-br/articles/115015741848

Para acessar a documentação no TDN acesse o link: https://tdn.totvs.com/x/qjr-IQ

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _