Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Framework - Linha Datasul - TEC - Out of free shared memory. Use -Mxs to increase (6495)

relogio.png Tempo aproximado para leitura: 00:01:26 min

Ocorrência
No log de banco de dados apresenta a mensagem Out of free shared memory. Use -Mxs to increase (6495)

Ambiente
Framework - Framework (Linha Datasul) - Progress OpenEdge – Todas as versões

Causa
O parâmetro –Mxs define uma área em kbytes de overflow de memória. O valor padrão é 16 kbytes mais 300 bytes por usuário (-n) dividido por 1024. Um valor superior, múltiplo de 16, pode evitar problemas de direcionamento de buffer pool.

Solução
O valor inicial do parâmetro -Mxs para OpenEdge 32-bit é definido da seguinte forma:

-Mxs = 16384 + [("-n" * 300) / 1024], sendo o valor do -Mxs definido em KB.

Para OpenEdge 64-bit o valor inicial do parâmetro -Mxs é definido da seguinte forma:

-Mxs = 16384 + [("-n" * 400) / 1024], sendo o valor do -Mxs definido em KB.

Para corrigir a situação o parâmetro -Mxs deve ser incrementado, sendo sugerido 20% a mais do que o valor definido atualmente. Caso não haja um valor definido, adicione 20% ao cálculo obtido nas fórmulas citadas neste artigo.

A alteração desses parâmetros necessita que o banco de dados seja derrubado e carregado novamente para que os novos valores sejam reconhecidos.

Importante
Este parâmetro deve ser alterado somente em caso de erro ou orientação do Suporte Técnico da TOTVS.

Saiba mais
Para mais informações sobre o parâmetro -Mxs consulte o Kbase da Progress What does the 6495 'Out of free shared memory' error mean?

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _