Ocorrência
Ao acessar o Ponto Eletrônico e tentar realizar manutenção em qualquer movimentação ou rotina, é apresentado error log: "PN090LOCK01: TOP Error -19 - [ERROR] Table PN090LOCK01 STILL IN USE".
Ambiente
Protheus - Gestão de Pessoal - Todas as versões
Causa
O erro ocorre quando na execução do Fechamento Mensal do Ponto e o sistema é interrompido por causa desconhecida (queda rede ou energia por exemplo), deixando a tabela temporária PN090LOCK no ambiente, o que acaba impedindo os usuários de acessarem as outras rotinas do módulo. Os arquivos do Ponto Eletrônico somente são liberados para edição após fechamento ocorrer corretamente até o final, com isso liberando os semáforos.
Solução
1. Para solucionar essa ocorrência, será necessário atualizar o ambiente após realização de backup, conforme pacotes abaixo:
12.1.17:https://r.totvs.io/p/1011313 ;
12.1.23:https://r.totvs.io/p/1011314 ;
12.1.25:https://r.totvs.io/p/1011315 ;
12.1.27:https://r.totvs.io/p/1011316 ;
Saiba mais
Pacote Acumulado do RH:
MP - GPE - Como fazer o download (baixar) do pacote de expedição continua (acumulado) do modulo Gestão de Pessoal
Pacote Acumulado e-Social:https://centraldeatendimento.totvs.com/hc/pt-br/articles/360051585234
0 Comentários