Tempo aproximado para leitura: 00:02:00 min
Ocorrência
No módulo Manutenção Industrial, várias funções utilizam componentes visuais do tipo OCX - Active Control. São as funções que utilizam alguma forma de comunicação visual como gráficos, imagens, fotos, envio de e-mail, entre outras. Para que essas funções funcionem corretamente, é necessário que todos os componentes estejam implantados e ativos.
Ambiente
TOTVS Manufatura - TOTVS Manufatura (Linha Datasul) - Manutenção Industrial (MMI) - A partir da versão 12
Causa
Quando os componentes não estão instalados corretamente, então, são apresentadas mensagens de erro Progress, informando que o OCX não está instalado ou não está devidamente registrado.
Solução
Para solucionar esse tipo de problema, é necessário executar os programas setup.exe das subpastas que se encontram no diretório \Interfac do diretório padrão de programas do EMS. Segue uma relação dos componentes de OCX e suas funcionalidades no produto:
- Activex ou Estruct - quando o programa utilizar alguma forma de visualização semelhante ao Windows Explorer.
- Calendar - quando o programa utilizar alguma forma de visualização de calendário.
- Gráfico - quando o programa utilizar alguma forma de visualização de gráficos.
- Imagem - quando o programa utilizar alguma forma de visualização de imagens, fotos, etc.
- Mail - quando o programa utilizar alguma forma de envio de e-mail.
- Barra - quando o programa utilizar alguma forma de visualização de barras.
- Som - quando o programa utilizar algum recurso de som no produto.
- Vídeo - quando o programa utilizar algum recurso de vídeo no produto.
- Treeview - quando o programa utilizar algum recurso de consulta em forma de árvore.
- VBTreelist - quando o programa utilizar algum recurso de consulta em forma de árvore, no entanto, com colunas.
Devem ser seguidos os seguintes passos:
- Desinstalar o <componente>, caso esteja instalado no painel de controle, nesse caso sempre apresentará o nome Datasul <componente> Exemplo: Datasul Imagem, Datasul Calendar;
- Reiniciar o computador;
- Executar o arquivo setup.exe que está no diretório <produto>\Interfac\<componente> que efetuará a instalação dos OCX's necessários;
- Reiniciar o computador;
- Executar o programa do Sistema que tenha apresentado problema de OCX.
0 Comentários