Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Manufatura - Linha Datasul - MMI - Utilização de recursos visuais, arquivos OCX

Tempo aproximado para leitura: 00:02:00 min

Ocorrência
No módulo Manutenção Industrial, várias funções utilizam componentes visuais do tipo OCX - Active Control. São as funções que utilizam alguma forma de comunicação visual como gráficos, imagens, fotos, envio de e-mail, entre outras. Para que essas funções funcionem corretamente, é necessário que todos os componentes estejam implantados e ativos.

Ambiente
TOTVS Manufatura - TOTVS Manufatura (Linha Datasul) - Manutenção Industrial (MMI) - A partir da versão 12

Causa
Quando os componentes não estão instalados corretamente, então, são apresentadas mensagens de erro Progress, informando que o OCX não está instalado ou não está devidamente registrado.

Solução
Para solucionar esse tipo de problema, é necessário executar os programas setup.exe das subpastas que se encontram no diretório \Interfac do diretório padrão de programas do EMS. Segue uma relação dos componentes de OCX e suas funcionalidades no produto:

  • Activex ou Estruct - quando o programa utilizar alguma forma de visualização semelhante ao Windows Explorer.
  • Calendar - quando o programa utilizar alguma forma de visualização de calendário.
  • Gráfico - quando o programa utilizar alguma forma de visualização de gráficos.
  • Imagem - quando o programa utilizar alguma forma de visualização de imagens, fotos, etc.
  • Mail - quando o programa utilizar alguma forma de envio de e-mail.
  • Barra - quando o programa utilizar alguma forma de visualização de barras.
  • Som - quando o programa utilizar algum recurso de som no produto.
  • Vídeo - quando o programa utilizar algum recurso de vídeo no produto.
  • Treeview - quando o programa utilizar algum recurso de consulta em forma de árvore.
  • VBTreelist - quando o programa utilizar algum recurso de consulta em forma de árvore, no entanto, com colunas.

Devem ser seguidos os seguintes passos:

  1. Desinstalar o <componente>, caso esteja instalado no painel de controle, nesse caso sempre apresentará o nome Datasul <componente> Exemplo: Datasul Imagem, Datasul Calendar;
  2. Reiniciar o computador;
  3. Executar o arquivo setup.exe que está no diretório <produto>\Interfac\<componente> que efetuará a instalação dos OCX's necessários;
  4. Reiniciar o computador;
  5. Executar o programa do Sistema que tenha apresentado problema de OCX.
Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _