Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

RH - Linha Protheus - PON - Error log no Fechamento Mensal: variable does not exist PC_DATA


Ocorrência

Ao realizar o fechamento do Ponto Mensal na rotina (PONM090), é apresentado error log: variable does not exist PC_DATA on { ||( !EMPTY(P8_DATAAPO) .AND. P8_DATAAPO <= DPERFIM .OR. ( (CALIASSRA)->( RA_SITFOLH == "D" .AND. RA_DEMISSA <= DPERFIM ) .AND. PC_DATA <= DPERFIM ) ) }(PONM090.PRX)

Ambiente
TOTVS RH - TOTVS RH (Linha Protheus) - Ponto Eletrônico - a partir da versão 12.1.27

Causa 
O erro ocorre por conta de fontes desatualizados

Solução
Para solucionar essa ocorrência, é necessário aplicar o pacote de Expedição contínua de RH.
Para saber como obtê-lo, clique aqui

Saiba mais
Documentação Técnica da correção
Soluções para error log

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

4 Comentários

  • Avatar
    JOSUEL COSTA

    Boa tarde,

     

    Quando se diz limpeza é dar um ZAP ou DELETE nos registros antigos constantes na tabela?

     

    Estou com esse problema em algumas Empresas do Grupo onde trabalho.

    0
    Ações de comentário Permalink
  • Avatar
    Luciano Lamberti

    Bom dia.

    A TOTVS não tem nenhuma tratativa na rotina de fechamento de ponto pra executar essa ação? Se está claro que no processo de fechamento os registros das tabelas não podem conter registros de períodos anteriores, porque a rotina não executa a limpeza automaticamente? 

     

    0
    Ações de comentário Permalink
  • Avatar
    WILLIAN UTSUMI DE ARAUJO (Editado )

    Olá JOSUEL COSTA!

    A documentação foi atualizada com o pacote de atualização do fonte PONM090, responsável pelo Fechamento do Ponto e que estava causando o problema. Ao invés de realizar o procedimento paliativo de limpar as tabelas, recomendamos apenas atualizar seu ambiente com o pacote disponibilizado, pois ele já corrige esta inconsistência diretamente no fonte.

    Att..

    0
    Ações de comentário Permalink
  • Avatar
    WILLIAN UTSUMI DE ARAUJO

    Olá Luciano Lamberti!

    Esta documentação foi criada no momento em que notamos a presença deste erro em algumas situações e, momentaneamente foi criada com um processo paliativo, apenas para não impedir a operação da Folha, quando dependente do Fechamento do Ponto, em situações específicas.

    Contudo, já estava mapeado a correção via fonte deste cenário. Inclusive, foi disponibilizado no dia de hoje (14/12/2020) o pacote oficial, com atualização do fonte PONM090, para que o fonte realize a tratativa e não seja necessário manipular as tabelas.

    Os pacotes disponibilizados já estão atualizados nesta mesma documentação!

    Att..

    0
    Ações de comentário Permalink
Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _