Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Agro - Linha Datasul - GGP - Problemas com a integração entre Originação e Totvs Agro Beneficiamento

time.png Tempo aproximado para leitura: 00:03:00 min

Ocorrência
O que verificar caso ocorra problemas com a integração entre Originação e TOTVS Agro Beneficiamento?

Ambiente
TOTVS Agro - TOTVS Agro - Comercialização (Linha Datasul) - Venda, Compra e Armazenagem de Grãos (GGP) - A partir da versão 12.1.28

Causa
Devido a configuração incorreta, ou alteração de alguma configuração, podem ocorrer problemas com a integração entre Originação e TOTVS Agro Beneficiamento.

Solução
A solução TOTVS Agro Beneficiamento com a Originação para atualizar os resultados das análises para cada característica técnica dos lotes API REST

A Originação por sua vez se comunica com o TOTVS Agro Beneficiamento para enviar o status dos lotes quando estes foram Faturados para um cliente ou Remetidos para formação de lote de exportação.

Quando ocorrerem problemas relacionados a não integração das características técnicas:

  • Simular na Originação, na função de Reclassificação, a partir da tela de gerenciamento
    html.ggp.lotes - Gestão de Blocos, se a apresentação das características, e sua
    atualização estão funcionando, pois são as mesmas APIs executadas na integração:

mceclip0.png

Caso ocorra o mesmo problema na simulação na tela de Reclassificação:

  • Verificar se o código da característica é válido no CD0213 - Manutenção Item Folha Especificação;
  • Verificar se o lote não está com algum status que impeça alterar o resultado da característica Take-up, Faturado, Remetido, deste modo não é possível alterar mesmo a característica;
  • Verificar se os lotes estão criados no ERP TOTVS Linha Datasul tanto no módulo de Estoque, CE0814 - Movimento Estoque, quanto na Originação Gestão de Blocos e Lotes, html.ggp.lotes.
  • Verificar se o serviço do Appserver está ativo e configurado corretamente.

Caso não ocorra problemas na simulação na tela de Reclassificação:

  • Verificar se o login e senha utilizados pelo TOTVS Agro Beneficiamento para conectar com o ERP TOTVS Linha Datasul estão corretos;
  • Verificar se não existe nenhum bloqueio de rede que impeça a requisição chegar ao ERP TOTVS Linha Datasul. Através do log do Jboss/Tomcat é possível saber se a requisição chegou. Pode haver problemas de rede, como firewall ou outros bloqueios;
  • Verificar se o Payload JSON informado está correto, tem todos os campos obrigatórios;
  • Verificar se o jboss/Tomcat e Appserver estão ativos;
  • Verificar se o TOTVS Agro Beneficiamento está usando o ambiente do ERP TOTVS Linha Datasul desejado, se não está apontando para uma instalação onde não existe o lote cadastrado que se deseja atualizar o resultado da análise na característica;
  • Verificar se o tipo de Logon está correto, enquanto o cliente estiver usando o Jboss deve-se gerar o cookie para acessar o ambiente. Quando migrado para o Tomcat deve ser informada a autorização do acesso através do Basic Auth, conforme documento do FrameworkDesenvolvimento de APIs para o Produto Datasul.

Quando ocorrerem problemas relacionados a não integração do status do Lote GG4091 - Integração Expedição Lotes x Agro Beneficiamento:

  • Quando apresentado o erro Secure Socket SSL, código de erro -54: unable to get issuer certificate - 9318, deve-se realizar o procedimento descrito no artigo Aplicação de certificados no Progress no Saiba mais, pois é a falta de certificado aplicado a instalação do Progress
    A questão do certificado é em relação a URL do TOTVS RAC, assim se for mudada a URL, trocado o servidor de instalação do Progress ou o certificado expirar validade, o processo de importação de certificado deve ser realizado novamente.
  • Verificar se há algum bloqueio de rede, exemplo Firewall.
  • Verificar se os dados estão chegando na solução de TOTVS Agro Beneficiamento.
  • Verificar se os dados de conexão estão corretos, checando o serviço através da URL http://urlBeneficiamento/api/swagger-ui.html;
  • Quando a integração apresenta sucesso é retornado o ID da movimentação do beneficiamento, deste modo, tendo o ID é possível verificar no Beneficiamento qual movimentação foi gerada.
  • A integração é realizada Bloco a Bloco, portanto todos lotes do mesmo bloco estarão com o mesmo ID retornado do beneficiamento.

Saiba mais
Para complementar, sugerimos visualizar também o documento técnico e os artigos listados abaixo:
DT Integração Originação de Grãos e Beneficiamento
Agro - Linha Datasul – GGP – Como funciona a integração com TOTVS Agro Beneficiamento na Originação?
DS - TEC - Aplicação de certificados no Progress

Glossário
API - Application Programming Interface
REST - Representational State Transfer
PAYLOAD - Carga de Transmissão de Dados
JSON - JavaScript Object Notation
COOKIE - Arquivos criados pelos websites
BASIC AUTH - Basic Authentication
URL
- Uniform Resource Locator
TOTVS RAC - Serviço de Autenticação da TOTVS
ID - Documento de Identificação

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _