Ocorrência
Ao executar o Agent, o mesmo está retornando o erro "Java heap space".

Ambiente
GoodData – Fast Analytics – Todas as versões utilizadas em sistema operacional Windows.
Causa
O Java alcançou o limite de memória disponível na aplicação.
Solução
É necessário instalar o java x64, que possui maior capacidade de alocação de memória.
Para solucionar essa ocorrência, realize os seguintes passos:
1. Entre na URL https://www.java.com/pt-BR/download/manual.jsp
2. Baixe o pacote conforme imagem abaixo.

3. Execute o arquivo baixado.
Durante a instalação o instalador pode detectar versões antigas do Java e caso encontre irá perguntar se o usuário deseja desinstalar as mesmas. É recomendado que não seja realizada a desinstalação, pois outras aplicações podem estar utilizando essas versões antigas.
4. Após o final da instalação, edite seu arquivo Run.bat e substitua o comando java pelo caminho completo do arquivo java.exe da nova instalação. Exemplo:
Antes da alteração:
java -jar agent-analytics-1.6.2.jar config.properties
Após a alteração:
"C:\Program Files\Java\jre1.8.0_261\bin\java.exe" -jar agent-analytics-1.6.2.jar config.properties
Importante:
Essa instalação não requer o reiniciamento do sistema.
Caso seja necessário definir manualmente a quantidade de memória do Java, consulte a documentação abaixo:
https://tdn.totvs.com/pages/releaseview.action?pageId=228589754
0 Comentários