Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Manufatura - Linha Protheus - SIGAPCP - Erro variable does not exist NPOSOPER on {|a,b,c| FWInitCpo(a,b,c),xRet:=(Soma1(aCols[n-1,nPosOper],2)),FWCloseCpo(a,b,c,.T.),FwSetVarMem(a,b,xRet),xRet }

time.png Tempo aproximado para leitura: 00:01:07 min

Ocorrência
Ao tentar cadastrar um roteiro de operação no MATA632 - Roteiros e Operação é apresentado o erro variable does not exist NPOSOPER on {|a,b,c| FWInitCpo(a,b,c),xRet:=(Soma1(aCols[n-1,nPosOper],2)),FWCloseCpo(a,b,c,.T.),FwSetVarMem(a,b,xRet),xRet }(PROTHEUSFUNCTIONMVC.PRX)

Ambiente
TOTVS Manufatura - TOTVS Manufatura (Linha Protheus) - Planejamento e Controle da Produção (SIGAPCP) - Versão 12

Causa
O erro ocorre pois há informação Soma1(aCols[n-1,nPosOper],2), no X3_RELACAO - Inic. Padrão, do campo G2_OPERAC - Operação.

Solução
Para que o erro não ocorra, deve-se limpar o conteúdo Soma1(aCols[n-1,nPosOper],2), do X3_RELACAO, do campo G2_OPERAC, da tabela SG2 - Roteiros e Operação.

Importante

Lembramos que a partir da versão 11.8 o programa MATA630 - Roteiro e Operações foi substituído pelo MATA632, por gentileza fazer um novo teste utilizando este programa.

Esse artigo foi útil?
Usuários que acharam isso útil: 1 de 1

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _