Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

TOTVS Construção - Obras e Projetos - TCOP - Mensagem de falha de HTTP ao tentar logar no Portal de Obras e Projetos



Ocorrência
No módulo TOTVS Construção, Obras e Projetos, ao tentar logar no Portal Top Web é apresentada uma mensagem sinalizando falha de HTTP.



Ambiente
RM - TOTVS Construção, Obras e Projetos - A partir da versão 12.1.2506 


Causa 
Esse incidente ocorre pois, na instalação do Portal da Obra, a porta do serviço do host pode estar diferente em relação a porta definida no ApiServer do config.json do Portal da Obra.


Solução
Para solucionar essa ocorrência, realize os seguintes passos:

1. Acesse a pasta de instalação do RM CorporeRM\FrameHTML\web\app\Prj\config

Configure o endereço da API utilizando o IP ou DNS do servidor, juntamente com a porta 8051 dentro do arquivo config.json;

 

2.  Acesse a pasta de instalação do RM CorporeRM\RM.Net\wwwroot\Config

Configure o endereço da API utilizando o IP ou DNS do servidor, juntamente com a porta 8051 dentro do arquivo config.json
 

 

3. Acesse a pasta de instalação do RM e defina a porta 8051 também para a TAG ApiPort dos serviços do host, RM.Host.exe.config e RM.Host.Service.exe.config;

Em seguida salve o arquivo, em seguida reinicie o serviço do Host.

 

4. Caso a configuração esteja sendo realizada apontando os config's para um IP EXTERNO ou DNS, é necessário que os mesmos estejam acessíveis, e liberados. Possuindo a DNS ou IP EXTERNO, o mesmo deve-se estar com a API ativa.

  • Para validar se está ativa, insira o endereço http://IPEXTERNO:PORTAAPI/api/swagger em seu navegador, substituindo pelos respectivos, IP e Porta Api e verifique se a tela do swagger será carregada com a palavra FETCHING. Se a página carregar corretamente conforme abaixo, quer dizer que a API esta ok. 
      
    IPEXTERNO: É o endereço liberado de acesso externo.
    PORTAAPI: É porta API configurada em seu host.exe.config
     
     

    Se a página do Swagger não for carregada corretamente, é possível que exista algum bloqueio de proxy e/ou restrição na rede interna, impedindo que o Swagger acesse os serviços das APIs por meio do DNS configurado.

    Nesses casos, recomendamos acionar a equipe de rede e infraestrutura da empresa para que sejam realizadas as devidas validações e ajustes necessários.


    Importante
    O IIS realiza interações com a pasta do site e ele deve ter permissão total de acesso a pasta. 
    É necessário inserir nas propriedades da pasta o controle total para o IIS NOMEDAMAQUINA\IIS_IUSRS.
     

 

Importante
A porta 8051 foi utilizada como exemplo para a documentação acima, é de extrema importância que sejam configuradas as mesmas portas para os arquivos citados, ApiServer e config.json.


Saiba Mais
Configuração de Instalação - Portal TOTVS Obras e Projetos e Cockpit TCOP

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _