Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmento - TOTVS Backoffice Linha Protheus - SIGAEIC - O campoA2_LOJA refira à pasta:1, mas não existe. on FWFORMFIELD:PREPAREFIELDS(FWFORMFIELD.PRW)

Ocorrência
Ao tentar incluir ou alterar um fabricante/fornecedor na rotina Fornecedores (MATA020) informa que o folder não existe do campo A2_COD.

Causa

O campo A2_LOJA refira à pasta:1, mas não existe. on FWFORMFIELD:PREPAREFIELDS(FWFORMFIELD.PRW) 05/03/2020 22:36:10 line : 408
mceclip0.png

Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus)  – Easy Import Control – Todas versões

Solução
A tabela SX3 faz parte do dicionário de dados e é responsável pela estrutura e ordenação dos campos de uma tabela.
Com isto, ao acessarmos a SX3 da tabela SA2 campo A2_LOJA e observarmos o campo X3_FOLDER, o mesmo possui conteúdo 3. isto refere-se a pasta onde o campo será alocado para apresentação ao usuário em tela, ou seja, no cenário abaixo está sendo informado na SX3 a pasta 1 que refere-se a aba Cadastrais para o campo A2_LOJA, mas esta pasta não existe pois não está sendo informada na tabela SXA que é responsável pela ordenação das pastas.
Isto ocorre devido a falta de atualização do dicionário de dados do cliente e execução do UPDDISTR.

SX3 do Campo filtrado na Tabela SA2:

mceclip1.png

Segue SXA filtrado na Tabela SA2:

mceclip2.png

Ao acessar o cadastro de Fornecedores:
- O erro informa que não existe a pasta 1 referente ao campo A2_LOJA, pois no X3_FOLDER foi informado que este campo se refere a pasta 1 mas se observarmos na tabela SXA que controla as pastas das rotinas do sistema, que só existem 8, sendo que o correto seria 9 pastas e a pasta "Cadastrais" onde fica o campo A2_LOJA não esta criado no ambiente do cliente.

Para corrigir:
- Faça um backup da SXA e filtre a SA2 ao encontrar registros delete.

-Inclua um novo registro via APSDU com a descrição Cadastrais conforme print:

mceclip3.png

Após a inclusão deste novo registro é só acessar a rotina de fornecedores que o erro não será mais exibido.

 

 

 

 

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _