Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

MP - SIGALOJA - Error log ao finalizar troca/devolução na rotina LOJA720: type mismatch on compare on A103NFISCAL(MATA103.PRW)


Ocorrência
No Módulo Controle de Lojas, ao finalizar o processo de troca/devolução, é apresentado o errorlog abaixo:

mceclip0.png


Ambiente
Microsiga Protheus – SIGALOJA – A partir da versão 12

Causa
Esse incidente ocorre devido a configuração incorreta no atalho do SmartClient.exe.

Solução
Para solucionar essa ocorrência, realize os seguintes passos:
1. Acesse as propriedades do SmartClient.exe;

mceclip2.png

2. Verifique a configuração do atalho do SmartClient.exe conforme documentação Parâmetros de linha do TOTVS | SmartClient e realize os ajustes necessários;

Atenção: este erro geralmente é ocasionado devido a espaços indevidos nessa parametrização.

  • Exemplo de configuração: -m -a= -a=002

mceclip3.png

Obs: A parametrização acima permite a execução de múltiplas instâncias do TOTVS | SmartClient na mesma máquina e está configurado para acessar a estação de código 002.

  • Exemplos de como NÃO DEVE ser configurado:
    • Incorreto: -m -a=-a=001 (espaço em branco não deixado entre o primeiro -a e o segundo -a)
    • Incorreto: -m-a= -a=001 (espaço em branco não deixado entre o -m e o primeiro -a)
    • Incorreto: -m-a=-a=001 (espaço em branco não deixado em nenhum dos três parâmetros)

3. Feche o serviço, abra novamente para carregar a nova configuração, realize o processo de Troca/Devolução e o erro não será mais apresentado.

 

Saiba Mais
Para mais informações, verifique: Como configurar os parâmetros de linha do TOTVS SmartClient

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _