Ocorrência
No Módulo Controle de Lojas, ao finalizar o processo de troca/devolução, é apresentado o errorlog abaixo:

Ambiente
Microsiga Protheus – SIGALOJA – A partir da versão 12
Causa
Esse incidente ocorre devido a configuração incorreta no atalho do SmartClient.exe.
Solução
Para solucionar essa ocorrência, realize os seguintes passos:
1. Acesse as propriedades do SmartClient.exe;

2. Verifique a configuração do atalho do SmartClient.exe conforme documentação Parâmetros de linha do TOTVS | SmartClient e realize os ajustes necessários;
Atenção: este erro geralmente é ocasionado devido a espaços indevidos nessa parametrização.
- Exemplo de configuração: -m -a= -a=002

Obs: A parametrização acima permite a execução de múltiplas instâncias do TOTVS | SmartClient na mesma máquina e está configurado para acessar a estação de código 002.
- Exemplos de como NÃO DEVE ser configurado:
- Incorreto: -m -a=-a=001 (espaço em branco não deixado entre o primeiro -a e o segundo -a)
- Incorreto: -m-a= -a=001 (espaço em branco não deixado entre o -m e o primeiro -a)
- Incorreto: -m-a=-a=001 (espaço em branco não deixado em nenhum dos três parâmetros)
3. Feche o serviço, abra novamente para carregar a nova configuração, realize o processo de Troca/Devolução e o erro não será mais apresentado.
Saiba Mais
Para mais informações, verifique: Como configurar os parâmetros de linha do TOTVS SmartClient
0 Comentários